Can't connect with hidden wifi

Hi. I changed my router to a new one and it has hidden wifi (internet provider rules), so i have to connect my mobile phone to the network manually. My bulb won’t connect since then. Tried the ‘on and off 5 times’ thing a few times. Not working. Help?

HIdden ssid is not supported. To work around this (if you can’t change your router’s setting), please use another phone as hotspot and set the ssid and password exactly the same as your hidden ones. Then connect your bulb through this hotspot. After the connection, you can disable your hotspot and the bulb will connect to your hidden router.

I had issues with hidden SSID with few other products. The trick is to unhide SSID (your base station name), and later on hide it.

Also, if you have Access Control or MAC Filtering, you will need to add mac address of your yeelight in your router.

on iOS, you can setup hotsport as per below:

@weiwei
How stupid is this? Such a basic thing, are you kidding? I payed 30CHF for this crap and i have to return it.
To work around this, get to work and add support for hidden wifi!
Users buy the bulbs to integrate with their home network, not to disrupt and create stupid phone hotpots just for a stupid bulb or set of bulbs…

Stupidity of these companies are really high.

Sorry for the rant, its just unacceptable and stupid. For such small thing i have to return it.