Can't add Ceiling Light to the Mi Home App!


so i’ve bought RGB Light Bulbs and the Ceiling Light. I’m pretty happy with it. Expect that i cant add the ceiling light to the Mi Home App.

I’ve added the light bulbs without any problems. Only the ceiling light is a problem. I’ve connected the remote control to it.

In the app itself there i no option for the ceiling light. If i click on add Device, there are only these devices : Mi Air Purifier2, Mi Air Purifier Pro, Mi Air Purifier, Yeelight Color Bulb, Mi LED Desk Lamp, Some Fan with chinese description, Zhimi Humidifer, Mi Robot Vacuum & Mi WiFi Repeater 2.

How do i add the ceiling light???

Which locale do you select in MiHome? Could you try with Yeelight app with the same locale?

Wie locale you mean Mainlaind China, Taiwan, Singapore and so on i think.

I mainly using Singapore, but ive tried a few others… Didnt changed anything.
these are the options i see

It’s kinda working in the Yeelight app… Didnt even know there was one LOL… i thought there was only the Mi Home App.

So in the Yeelight app i have the problem while it connects it randomly stops at like 20% or so.

I’ve resetted it multiple times didnt helped… whats the issue:(

Could you logout the app and login again?

Cause Ceiling light has not been sold abroad officially. There’s no Ceiling light option if you don’t select “Mainland China” locale. So if you want connect Ceiling Light via MiHome, please change your locale to “Mainland China”.

However, You can connect to Singapore server by Yeelight application.

BTW, could you see red cross after it stoped at like 20% or so?

I have Mi Home and Yeelight app installed. In Yeelight app I added the ceiling light. If I want to add to Mi Home app too, it ask me to factory reset the device. It is possible to add ceiling light to both app in the same time?

I want to control my ceiling light with Xiaomi wireless wall switches. In Yeelight app alone I can’t use the Xiaomi switches, I think.

MiHome and Yeelight share the same cloud server, and Mihome support Ceiling light only in Mainland china server. So please select Mainland china server, the lamp will appear in both apps if you connect it successfully.

Yeah, probably this is the problem. Mi Home = Mainland China, Yeelight = USA server. I reseted the light, changed the server location (I tried all) and when I want to setup again I see the light, but I am unable to connect to it. :frowning:

I already reseted the light, deleted light from the original server (USA), reseted again, but I am still unable to add to any server (including to original USA).

When it is worked I updated all lights to the latest available firmware.

Can you check? MI ID 1676415005

I can ping all servers, nothing is blocked from my side:

adrian@MacBook-Pro:~$ ping

PING ( 56 data bytes

64 bytes from icmp_seq=0 ttl=53 time=56.156 ms

64 bytes from icmp_seq=1 ttl=53 time=56.913 ms

adrian@MacBook-Pro:~$ ping

PING ( 56 data bytes

64 bytes from icmp_seq=0 ttl=39 time=304.104 ms

64 bytes from icmp_seq=1 ttl=39 time=326.960 ms

adrian@MacBook-Pro:~$ ping

PING ( 56 data bytes

64 bytes from icmp_seq=0 ttl=45 time=303.392 ms

64 bytes from icmp_seq=1 ttl=45 time=322.203 ms

More info: I tried to set up from my iPad, at this time while connecting blinked around 10-20%, so I think it was registered successfully on the server (mainland china), but it doesn’t show up in my devices. Very weird.

After restarting my phone (iPhone 7) / mainland china server /, a popup window showed up to accept new privacy policy and I was able to add finally:

First light: added without problem
Second light: added, around 10-20% it blinked multiple times, but counter in the app still counted to 100% then Connection Failed. I quit the pairing process and the light showed up normally in my devices after few seconds. Weird.
Third light: same as second light
Fourth light: added without problem
Fifth light: added without problem
Sixth light: same as second light

All my lights are on FW 1.5.9_0184

You guys definitely need to improve registering process.

From your ping result, it seems Germany server is best choice for you to connect.

Let me explain the process of the connection:

  • Connect iphone to the lamp hotspot and tell the lamp SSID and password
  • The lamp disconnect your iphone, and try to connect mi cloud with SSID and password.
  • Your iphone request status of the lamp to see if it is connected.

I think the problem is in Step 3, your lamp has connected but your iphone query process timeout. So if you connect to us or china server, this may happen, cause your ping average is over 300ms.

Unfortunately I need to use Mainland China, because only this way can I connect my Aquara switches trough Mi Home app.

But 300ms ping isn’t much from my opinion, it should work even like this.

Maybe connection timeout is a little shorter, anyway, you have connected lamps successfully. That’s ok for controlling.

Please add the Yeelight 450 to the European server. Can’t be too hard?