Can not Connect to Yeelight Color LED Bulb


#1

Hello!

I bought a Yeelight Color LED bulb not so long ago, I downloaded MI Home and Yeelight application to my Android OS phone, logged into my Mi Account and added the bulb and updated the bulbs firmware, so everything worked fine. I chosed the Singapure server, because I live in Europe.
So as I said I could connect to the bulb and update the firmware too, and both the Mi Home app, and the Yeelight app worked fine with the bulb.

So everything worked fine until last Saturday ( April 1st), that evening I started the Mi Home app and it showed the LED bulb offline, I turned the light switch off and on again, but the bulb was showed still offline so I decided to reset the bulb with 5 times on - off turning for 2 seconds.

I did this and now I can see the LED bulb online, but when I want to connect to it, it goes up to 90% in the Mi Home app, and than “Connection timeout” . I tried the Yeelight application too, but '“Connection timed out” there too.
Than I tried to switch to the China Mainland server and reseted the LED bulb again but it was the same “Connection Timed out” at 90% Updating connection status …

I tried everything, multiple server but always connection timed out. I can see the MAC address of the bulb in my router and it gets an IP address from the DHPC server, so I dont understand what happened why I cant connect to it?

Can you please help me somehow, or tell me what else could I do to make it work again?
Maybe something with the firmware went wrong, could you revert it to the old version, or check my Mi Account?
Help me please, thank you!


#2

Please let us know your mi account. Also, please try to ping “ot.io.mi.com”. If you have WeChat or Whatsapp, we can do some live debugging.


#3

Hello!

You need this 10 digit number of my Mi Account or the e-mail address or name?
My Mi Account number is 1626479825 , I also installed Whatsapp on my phone , so we can try to fix the bulb somehow.
:slight_smile:


#4

Hello again!

My Xiaomi Account number is 1626479825 , I also installed WeChat and Whatsapp to my phone so we can communica on them.
I tried to fix the bulb, and reseted it multiple times. I tried all the servers in the Mi Home application but always the same happens, “Connection timeout” at 90% .
I tried it with 2 different router , 2 different 2.4 Ghz Wifi , but always “Connection timeout” at the end.

I guess something wrong with the firmware on the light bulb maybe, but still very starge because I can connect to the bulb directly with my phone at the Wifi section, I can also ping “ot.io.mi.com” without any problem on my phone and computer too.

I also tried to open prots and set static IP to the bulb but still not working , not connecting in the applications.
Can you somehow connect to the bulb and check the firmware or update it, or send me the file and tell me how to update it manually myself?


#5

My Wechat id is “Andydingding”, I am here to support.


#6

Hi Guy’s…
Same problem cut’s off at 90%
what was the solution.


#7

I am having the same issues


#8

Pleas use another phone as hotspot, see if the lamp can connect successfully.


#9

After almost 2 weeks of not working and connecting, I tried to connect it today and it works again. I could connect to the bulb with MI Home application.
I tried all the solutions before and none of them worked, the problem was maybe at my ISP or something with the DNS servers, or anything else network related.
At least it is working again. :slight_smile:


#10

Mine is not working also, can’t be found (just showed ‘redresh’). But even i tried several times to refresh, I don’t succeeded. Last effort I tried to reset all 10 Yeelight, but they’re can’t succeed either. I guess this is related to the newest firmware. I updated the firmware and for a couple of days they’re began to break up. I still have 1 Yeelight that not connected to Singapore (I used this one with MI home, the other 10 I user with alexa), but connected to mainland n I’m not upgrade the firmware (I forgot). And still functioning.


#11

Could you please drop a mail to support1@yeelink.net and provide more details? Engineer will help to check!


#12

Have the same issue here. Bought two of them and none of them can connect to wifi. Not even to hotspot. I spent hours reseting the router and the bulbs and trying with android and ios devices. Read about this issue but it got me nowhere. Can you please help? MI ID:1810631653. With ios its sometimes stuck at 25% or often at 0 and gives me the cannot connect message. With android it goes up to 99% with no different conclusion. This is a huge dissapointment for me. I was so excited about them. Now I’m not. They r just very expensive white bulbs with a bad memory of a failed struggle for me now. (Oh it can change color when i reset them, to be honest)