[BUG] Bulb stops to respond to M-SEARCH discovery after some time on fw57

Hello. I have YLDP02YL and I’ve updated its firmware to the latest one (1.4.1_57 in app and fw_ver: 57 in the API response). Immediately after bulb reset (with 5 on/off cycle) it responds to discovery broadcast message several times but later it stops to do that. I suspect it’s a firmware bug.

If you reset the bulb, it will lost connection to router, how could you see the message?
I suggest you check your code or provide a traffic capture file to us.

@weiwei I’m sorry, you get me wrong. I mean that the bulb didn’t respond to my broadcast message, so I’ve reset it and I started to get responses. But after several minutes it stopped to respond again. I’ve reset it again and it started to respond again but only for a few minutes. I’m talking about the discovery process, when the app sends broadcast and the bulb responses with some information like ip address, firmware version and so on. The issue is not in the code, I tried to use an existing python library with the same result. Even more, there is an issue raised against this library, but as far as I can see, there is no problem in the library itself, but in the bulb. Here is the link to that issue: https://gitlab.com/stavros/python-yeelight/issues/9

@weiwei Sorry. I’ve discovered that this topic has been already discussed here: http://forum.yeelight.com/t/bulb-stops-to-respond-to-ssdp-requests-after-some-minutes/702/2 and here: http://forum.yeelight.com/t/python/69/10

Disabling IGMP snooping seems to help.

Good to know.