Bedside Lamp 2 Huge Lag and Flaky Operation


#1

I received two Yeelight Bedside Lamp 2 Wifi unit’s today as my first foray into Yeelight, but I’m really not impressed so far. I may be doing something wrong though so please let me know if what I’m experiencing is normal or not.

First off the lamps updated to 1.5.5_0164 straight away (from 1.4.something) - is this an ok firmware level?

Control via the iOS app is very laggy (both Mi Home and Yeelight) - I press a scene and it changes some 5-10 seconds later. I change the colour or brightness in the app and again huge delay before the lamp catches up. This happens to both lamps, with one of them close to the wifi access point. Both are on a 2.4Ghz wifi. I reset one of the lamps but it still had the same issue.

Pinging the lamps results in many packet losses which would explain the delayed reaction. Is wifi generally flaky on these lamps? I have other wifi devices on my network that don’t loose packets at all so something isn’t right.

Physical colour changing is unpredictable. I know that you can press the mode button to change between reading, colour, and colour flow. To change reading temperature you’re meant to hold the mode button and swipe in a circle on the top. However if I hold down the mode button and try to swipe on the top, it sometimes changes modes rather than colour. I can see the same problem if I just hold the mode button down - I would expect it to do nothing while it waits for me to change colour, but instead it changes mode. (I’m pressing the button firmly). This happens on both lights!

Trying to change the brightness is flaky too - it doesn’t smoothly transition between temperature when circling the top, or do it consistently. Sometimes it works and sometimes not. It’s very frustrating to use.

So, is this normal or do I have faulty units? Thanks in advance!


#2

That’s ok, it is latest firmware version online now.

Which server do you select? Could you post the ping result of “sg.ot.io.mi.com”, “us.ot.io.mi.com” and “ot.io.mi.com” to see which server it will be more stable?

BTW, if your phone connect the same wifi with your lamp, you can enable “LAN Control” to have a try.


#3

Thank you for your help dingyichen.

I’m on the US server at the moment, and I can see that LAN control was already enabled.

Ping results show the following which implies the US one is best for me.

$ ping sg.ot.io.mi.com
PING sg.ot.io.mi.com (52.221.85.229): 56 data bytes
64 bytes from 52.221.85.229: icmp_seq=0 ttl=43 time=371.023 ms
64 bytes from 52.221.85.229: icmp_seq=1 ttl=43 time=371.896 ms

$ ping us.ot.io.mi.com
PING us.ot.io.mi.com (35.167.218.97): 56 data bytes
64 bytes from 35.167.218.97: icmp_seq=0 ttl=39 time=177.771 ms
64 bytes from 35.167.218.97: icmp_seq=1 ttl=39 time=179.394 ms

$ ping ot.io.mi.com
PING ot.io.mi.com (42.62.48.113): 56 data bytes
64 bytes from 42.62.48.113: icmp_seq=0 ttl=43 time=288.963 ms
64 bytes from 42.62.48.113: icmp_seq=1 ttl=43 time=287.501 ms

It seems a little bit more responsive this morning, but there’s still a 1-2 second delay between phone and lamp. If this is normal (?) I can live with it.

Is it normal for the lamp to change mode when holding the mode button down? It always changes to colour mode each time I press it when in reading mode, so I think this is what’s causing it to change modes when I try to just change the colour temperature in reading mode. Unfortunately this is quite frustrating to use as a result.


#4

Yes, US is the best one for you.

After you send a command from the phone, the message path would be phone --> cloud --> router --> the bulb. When the bulb makes some changes, there’s a callback to notify others, and the message path is from “the bulb --> the cloud --> phone”, so if there will be some delay if the network is not very good. And if the phone is in the same network with the lamp and LAN Control is enabled, the message will be transfer in your local network, it should be more fast.

This is made by design, cause when you hold the mode button down, there’s an indicate circle to init/show current state.


#5

Thank you!

If the LAN option is enabled, is there any way to confirm that it is using the LAN rather than cloud? Are there any logs files I could look at for example?

Also, can the LAN option only be enabled via the Yeelight app or can I also use Mi Home (at the moment I have my two lamps configured with one on each app - I’ll move them both to Yeelight if needs be).

Could I force LAN use by blocking the US server on my router - would they still work?


#6

In the page of “Account Center”, click ten times in a row of mi account, you will enable “developer mode”. If the lamp using LAN, you will see device name with suffix “(LOCAL)”.

Only Yeelight application has LAN option.

Currently it can’t work if your router can’t access us server, we will make some optimization to do it.


#7

Thanks Andy!

Should I see the local suffix in the following screenshot, or is it somewhere else?


#8

That’s right, the suffix of -57 is RSSI (Received Signal Strength Indication) of the lamp from your router.

The screenshot below is mine, you can see that device I make in red rectangle is in LAN Control. As you can see, there is also another suffix of “-1 ℃”, this means temperature of the chip. Not all of the devices support it, -1 means no result back.These information just for debugging. It seems your application is not up to date, the latest version is 3.1.11.


#9

It seems your application is not up to date, the latest version is 3.1.11.

Ahh yes, it seems the iOS app just updated last night to 3.1.08, and developer mode shows the temp value now.

Can I check I’m looking at the right place to enable LAN control because both my devices don’t show LOCAL as per your screenshot (mine below):

To check Local Mode I go to a device, press the “eject” button bottom right (triangle with line underneath), press the LAN Control button (with lightening bolt icon), and I see LAN control is enabled. Is this right? If so, what can I do to troubleshoot why they aren’t showing the LOCAL suffix?

Thank you!


#10

Yes, you are right to enable Local mode.

You can have a try with Android phone, IOS doesn’t show LOCAL suffix, we will add it in next version.


#11

ahh ok that makes sense, thanks. Do the numbers -46 and -51 indicate a local connection? No worries if not as happy to wait for the next version.

Thanks.


#12

It is the value of RSSI (Received Signal Strength Indication), usually if it is smaller than -70, it means the signal is weak, seems yours are ok. And you can google it by the way.


#13

That’s signal strength in db.