A bothering issue with Yeelight E27 RGBW


#1

First of all, I’m going to say hi to every one of the members and staff in forums. This is my first post in here. And there is some good news and a little bit bad news :confused:

I have bought 2 Yeelight E27’s and been using them for few months and they offer me a quite enjoyable experience :kissing_heart:

At first there was this issue, which I solved it by myself. But still I want to mention it because it may provide benefit for other members that facing this issue. And that issue was one bulb frequently goes offline, maybe 5-6 times a day. At first I thought that one bulb was defective, but there is no offline problem since I changed my phone. I know, this is strange but upgrading my phone had completely solved “offline” problem. My previous phone is Redmi 3, and now I’m using Redmi Note 4 Global. Yeah, I’m a little bit of Xiaomi fan as you can tell :heart_eyes:

Anyway, come to the point of the actual problem I’ve been facing and this is so bothering, and I haven’t be able to solve it yet. That is when the electricity goes off and comes back on, both bulbs become offline :worried: And never ever ever goes online, until I manually turn them off and on. This is so bothering because when the electricity goes off and comes back in the middle of the night the bulbs turn on automatically and I have to get out of my bed and manually turn them off.

Or the other scenario is when I am away from home I need to control my lights remotely because safety reasons, you now what I mean. But if the electricity goes off and then on when I’m away, then I never be able to control my lights until I get to home and manually turn them off and on.

Anyways, I hope I could explained myself clearly and any help from you guys would be highly appreciated. Bye.


#2

The bulb will be automatically connect to the route after power outage. Could you check if your other device works well after power outage.

And there is a setting in Yeelight that you can enable it which names “Default state”, you can enable “Save light state automatically”. So if you encounter power outage again in the night, the bulb will stay in off state.


#3

Dear dingyichen. The problem has solved 50% thanks to you. I set the save light state automatically, and now it doesn’t turn on automatically when the electricity comes back. Thanks for the tip.

But the other problem is continuing. It won’t connect to the router when the electricity comes back. But my other devices can connect without a problem.


#4

Could you have a try with:
1、Disable your router;
2、Setup a hotspot with another phone with the same SSID and password with your router (So the bulb can automatically connect to it), thus you can see the bulb online in Yeelight application;
3、Simulate environment of electricity going off. Power off your bulb and disable your hotspot at the same time, then power on bulb and enable your hotspot to see if the bulb can be connected automatically.

I don’t the reason what’s going on, I suspect that there’s something happened with your router, so have the test to see if this is an issue with your router. BTW, which type of your router?


#5

I had a similar issue, I have 11 lights.

I have no idea if this is correct or not but I put it down to a race condition occurring in the router.

The way I solved it was by issuing each bulbs MAC address it’s own unique static ip via the router. Since then I have not had this issue.