Yeelight Striplight Connection Timed Out


#1

Dear Yeelight Team,

Today I received 2 No’s of Yeelight Strip flight which I ordered from Gearbest. I’m from India.

I have tried to setup using all server’s US, China, Singapore & Germany. But Connection Timed out error persist.
While on hotspot once I got 100% but then Connection Timed out.

Please help to solve this issue.


#2

For the connection issue, you can check by the following steps to see where the problem is:

1)Reset the lamp and then see if there’s AP named like “yeelink-light-***” in your phone’s wifi list? If yes, go to see Step 2; If no, it means there’s something wrong with the wifi module of your lamp;

2)In Yeelight/MiHome application, add the lamp you want to connect. Make sure there’s no special character of your router’s password. If the connection successes, congratulations, if not, go to Step 3;

3)See if the lamp in your router’s DHCP list, if yes, it means there’s something wrong with connection between your router and Mi cloud. Please have a check with your ISP if it blocks some domain of xiaomi. If there’s not the lamp in your router’s DHCP list, it means, the lamp has problems to connect to your router. So please have a check if your router block the lamp or your router has connected as more devices as it can connect.

So please have a check that which step do you stuck?

And at last please use another phone to setup a hotspots with 4G network and try connect the bulb to it, I want to make sure if the bulb is ok.

Thanks
Andy


#3

Dear Andy,

I’m facing issue with connecting Router with Mi Cloud. I can see Yeelight associated in DHCP list of router.
I have checked both the devices i purchased online, facing similar issue in both the units.

I have tried even connecting with 4G Data Connection, same issue in that too. Connection Timed Out it shows.

Find below ping results after yeelight is connected to WiFi router.:-

C:\Users\10463980>ping sg.ot.io.mi.com

Pinging sg.ot.io.mi.com [13.228.161.182] with 32 bytes of data:
Reply from 13.228.161.182: bytes=32 time=65ms TTL=47
Reply from 13.228.161.182: bytes=32 time=85ms TTL=47
Reply from 13.228.161.182: bytes=32 time=77ms TTL=47
Reply from 13.228.161.182: bytes=32 time=67ms TTL=47

Ping statistics for 13.228.161.182:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 65ms, Maximum = 85ms, Average = 73ms

C:\Users\10463980>ping ot.io.mi.com

Pinging ot.io.mi.com [42.62.48.115] with 32 bytes of data:
Reply from 42.62.48.115: bytes=32 time=363ms TTL=43
Reply from 42.62.48.115: bytes=32 time=442ms TTL=43
Reply from 42.62.48.115: bytes=32 time=373ms TTL=43
Reply from 42.62.48.115: bytes=32 time=374ms TTL=43

Ping statistics for 42.62.48.115:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 363ms, Maximum = 442ms, Average = 388ms

C:\Users\10463980>ping us.ot.io.mi.com

Pinging us.ot.io.mi.com [52.36.168.6] with 32 bytes of data:
Reply from 52.36.168.6: bytes=32 time=285ms TTL=35
Reply from 52.36.168.6: bytes=32 time=283ms TTL=35
Reply from 52.36.168.6: bytes=32 time=299ms TTL=35
Reply from 52.36.168.6: bytes=32 time=286ms TTL=35

Ping statistics for 52.36.168.6:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 283ms, Maximum = 299ms, Average = 288ms

C:\Users\10463980>ping de.ot.io.mi.com

Pinging de.ot.io.mi.com [52.57.237.31] with 32 bytes of data:
Reply from 52.57.237.31: bytes=32 time=173ms TTL=43
Reply from 52.57.237.31: bytes=32 time=128ms TTL=43
Reply from 52.57.237.31: bytes=32 time=135ms TTL=43
Reply from 52.57.237.31: bytes=32 time=138ms TTL=43

Ping statistics for 52.57.237.31:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 128ms, Maximum = 173ms, Average = 143ms

I don’t want my devices purchased to go waste. Else I need refund.


#4

Dear Andy,

I’m India, Mumbai City. I have tried to Connect from Singapore, Mainland China, US, Germany. For different server’s i have reset unit before connecting. You can see i’m getting response from ping. So it is also clear that ISP is not blocking.

Please help me on priority.


#5

Please update on this.


#6

Hi, do you have other wifi based devices?

Actually, I got no idea about the issue, it seems there’s something wrong when the strip try to connect to the cloud. I have mailed to xiaomi cloud engineer for help if there is a way to have a analysis.


#7

Dear Andy,

This is not a solution. I need solution. I have imported this unit. It must work. Wifi based devices means?

My mobiles, laptops does work with the router.

Please provide solution on priority. Add me on Wechat with your engineer to solve my issue. I need to buy more units. I’m already stuck in 2 units. How can i handle 100 units.


#8

Please provider your xiaomi account.


#9

Same problem 5161288339


#10

5164734300 is the account number . please help me on priority.


#11

Hi, Could you have a try with below:

1、Get IP address with command “ping sg.ot.io.mi.com”, it is like “13.228.161.182” (Use sg.ot.io.mi.com for Singapore server, us.ot.io.mi.com for US server, de.ot.io.mi.com for Germany server and ot.io.mi.com for Mainland china server);
2、Setup a local DNS server with your PC (You can use tool of simple dns), add an “A record” with the IP address you get from Step 1 associate to “sg.ot.io.mi.com”;
3、Modify DNS server of your router to the dns server you have setup in Step 2;
4、Reset the bulb and try to connect again to see if it works.

Thanks,
Andy


#12

@Satyamsaxena @brsrajan

we have found root cause of the issue, more information please refer to the page of

Sorry about the issue.

Thanks,
Andy