Yeelight is not responding


Today I installed the yeelight and installed the Mi Home app. Everything worked fine. It installed correctly and I can see the light bulb in the Mi Home app. But now I can’t do anything with it.

It keeps standing on this screen, and I can’t control the yeelight. If i press the connected Yeelight Color Bulb, nothing happens.

Can you please tell me how I can controll the yeelight with this Mi Home app?

We will take a look at it, which locale do you select?

I tried everything. From the recommended United States server, or Singapore server or China server, it doesn’t matter.

Some times when I reset the bulb and try the process all over again, the connection will time out. So there are different things going on.

Does one particular server exist for The Netherlands?

Today I have connection time outs on all my Yeelights.

The bulb is shown in my WIFI settings. I can connect to it. The Mi Home app also sees the bulbs. But if I want to connect to them, the connection times out after it reaches 95%.

The bulbs are also not shown in my WIFI router as connected.

Any help?

I also tried using two telephones (android) and create a hotspot. The telephone sees the bulb connecting to the hotspot, but the connection times out at 95%.

Do you have a WeChat or Whatsapp account? So we can do some live debugging.

Hello WeiWei,

I do have whatsapp. Do you want my phone number for that?


I have not heard anything from you in a while. Can you please give me help?