Yeelight color connection time out at 99%


#1

I am unable to connect to my bulb over wifi. When I add device it times out everytime at 99%.

I am able to add device if I use mobile hotspot.

I have a netgear CG3000v2 modem. I have tried resetting bulb, router, changing settings on router. etc

Any other ideas?


#2

Please try to ping “ot.io.mi.com” and “sg.ot.io.mi.com” with your wifi network. See if they are reachable?


#3

Pinging sg.ot.io.mi.com [52.221.85.229] with 32 bytes of data:
Reply from 52.221.85.229: bytes=32 time=286ms TTL=41
Reply from 52.221.85.229: bytes=32 time=306ms TTL=41
Reply from 52.221.85.229: bytes=32 time=281ms TTL=41
Reply from 52.221.85.229: bytes=32 time=278ms TTL=41

Ping statistics for 52.221.85.229:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 278ms, Maximum = 306ms, Average = 287ms

Pinging ot.io.mi.com [42.62.48.112] with 32 bytes of data:
Reply from 42.62.48.112: bytes=32 time=319ms TTL=36
Reply from 42.62.48.112: bytes=32 time=410ms TTL=36
Reply from 42.62.48.112: bytes=32 time=314ms TTL=36
Reply from 42.62.48.112: bytes=32 time=322ms TTL=36

Ping statistics for 42.62.48.112:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 314ms, Maximum = 410ms, Average = 341ms


#4

The connection blocks at 99%, it means there is something wrong when the device connects with the cloud.
Seems the result of ping is ok. So could you add DNS 8.8.8.8 to your router and try again?


#5

Unfortunately the DNS settings are locked on this router.

Would there be any workaround?


#6

I am not sure if this works, you can try use another phone as hotspot and set the ssid and password exactly the same as your router. Then connect your bulb through this hotspot. After the connection, you can disable your hotspot and enable your router to see if the device is online?


#7

Unfortunately that did not work either