Yeelight Alexa Skill is officially published !


You can use MiHome app, just switch it to Singapore server. However, if other type of devices doesn’t support Singapore server, you will lose control of them.


Can’t get the scene to work. Discovered “living room light” as a yeelight bulb, and a few scenes discovered as well. An example was “warm white” scene.

Then I tried this phrase, among other variations, but still couldn’t get scene changes to work:
“Alexa, set the living room light to warm white scene”

Any tips on how to get scene changes to work?


You don’t have to say that, just say “turn on warm white”. Scene is not designed for single device adjustment actually, it’s some state of your entire lighting (for example, a scene named “movie” could be: turn off main lights, turn your light strip to blue color. When you want to watch movie, just say “turn on movie”).

BTW, per Alexa certification, an account can only create at most 12 scenes, so please be conservative in scene creation, leave it to most common case, e.g. “leave home” instead of “pink”.


Thanks for the clarification.

I haven’t tried yet - but I think a workaround in my use case is name the scene per device - for example, “bed room warm white”, “living room warm white”, “kids room warm white”.

It would be nice as a future enhancement to be able to control scenes on a per-device or per-group basis.

With Alexa integration, I think Yeelight is going to get even more popular.


Thanks! Please wait for our App update, which will make scene management more intuitive and usable.


still waiting for logitech Harmony Support…


Send mail to Logitech, still no response …


Thank you very much for creating this skill.
I have had these bulbs a while and was using my own skill controlling the API.
I’m glad the skill has finally gone live.

i have noticed there is no colour and scene modes avaliable.
it would be sweet if you could add them.

I being a Alexa Dev, can help you if anything is needed.

Thanks again,


Thanks for your support! Regarding color changing, Alexa smart home skill doesn’t provide the interface, so we can’t do anything about it. For scene, you can use Yeelight app to create scene.


Alexa doesn’t see my YeeLight lamp. why?
I have switched server, delete and add device again, enable and disable skills few times.
But alexa on discover new device doesn’t see the lamp.


Check this out Collecting Echo & IFTTT feedback


Gave it a try and still can’t discover my Yeelight Lamp in Alexa App. I’ve tried deleting both Yeelight app and Alexa app, reset and reconnect several times, and no still no luck. Any suggestions? I’m gonna give it a last try and if that doesn’t work, I’m not gonna waste any more time


The skill is only available in UK, Germany and US, please make sure your amazon account is registered in above countries.
Also, please make sure you are using Yeelight WiFi based devices (Yeelight bedside lamp is not supported since it’s bluetooth device).


The Logitech Support Hotline is very good, i called them last week. Perhaps you can also call Logitech?


I’m going to give it a try but how do i switch to singapore server?


In Yeelight app, goto settings, change locale to “Singapore”, reset your bulb by on/off 5 times, then reconnect the bulb.


Tried with yeelight led color bulb and works. Cool!
Does it work with lightstrip too?


All Yeelight WiFi devices are supported.


Well done guys!

Just using it simply for now controlling on/off, will configure more in the coming days.


I just have a question I was the beta user of the Alexa skill should I do anything to update my smart home skill to latest Yeelight version?
Definitely good work and I should get more Yeelight bulbs, cheers