Very disappointed with reliability of Yeelight ceiling light

I have just moved into my new place and it has new lights 3 x YLXD01YL Yeelight Ceiling light and 1 x YLXD05YL JIAOYUE 480.

The YLXD05YL JIAOYUE worked for 1 night after installation, the next day I got home to find it ON by itself. I switched it OFF by wall switch, I could not turn it ON after that.

One of the Yeelight Ceiling Light YLXD01YL which is used for like 5 minutes every alternate day failed after one month. At first it would switch off by itself after turning on about 30 seconds. Now it does not turn on at all.

All lights firmware are up to date. Is there anything that I can do?

Items does not have any warranty support in Singapore as I bought them online.

Hi, these all look like hardware issues. If the power unit goes wrong, the ceilings won’t light up.
Or maybe there are environmental issues because it’s really rare to see 4 faulty ceilings in a row. Have you happen to installed them after a dimmer? Are they installed properly (no deformation with the docker, wires connected firmly, etc )?
After all, if above issues are all ruled out, and you are able to bring them back on, maybe you’d like to try out the firmware versions in beta; in that case, please PM with your MI id.

Hi ,

You misunderstood. 2 out of 4 light that I have is having issues.

Sometimes they cannot be turn on. Sometimes they can be turn on but turns off by itself after a few seconds or after 30 minutes. Totally unpredictable and unreliable.

No dimmer, no deformation of docker, no issues with wires because when I put the other lights that I have at their positions, there was no problem at all.

The 2 problematic lights are:

Yeelight Moon model: YLXD05YL
S/n: YL035/00003036
CMIIT ID: 2017DP4673

Yeelight Ceiling Light model: YLXD01YL
S/n: 15496/00040527
CMIIT ID: 2016DP7526

Thanks

Have you managed to solve these issues? I’m considering to buy Yeelight ceiling lights, but not if reliability is an issue…

This looks like hardware failure. Please contact the retailer for helps.

Reliability is never the issue. All companies have the same amount of defect in their products, people just tend to be subjective. If you buy i.e. Xiaomi phone and it breaks abter a month, you will say to everyone that Xiaomi phones are unreliable. Which is total bulls*it. All comapnies have approx same amounts of defects. But since it was you, they must be bad, right? And you come to forums and all you read are problems, right? Well, ofcourse, since if people didn’t have problems, why would they COME to forums? Go to any forum of any company and you’ll see complaints…

so… I have like 40 devices from Xiaomi ecosystem. And guess what? they all work. NEVER had a problem with connecting, never had a failure. I have 10 Yeelight products and they all work. v1 white and RGB bulbs, v2 white and RGB bulbs, led strip, 2 ceiling lights… all work.

but that must be a coincidence, right? Since MY bulb doesn’t work :slight_smile: But I probably WILL NOT GO TO FORUM and write “hey everybody, I have a product and it works!!!” right? Only if it doesn’t work will I write…

So, everything is SUBJECTIVE. Keep that in mind :slight_smile:

Cheers

1 Like

Wow, really, never had an issue?
I’m from the IT industry and have yet to come across such a god like product/brand all these years.
I really hope you can prove me wrong though.
I had been using 34 multi colour yeelight, 1 hub and 7 switches for the past 1.5 years.
Today when I press the smart switch or issue command via Google assistant. My yeelight still fail to work like 30% of the time.
Like 1 out of 4 lights in the room will refuse to react. I had reseted and reconnected then once so far.
Internet connectivity is great here in singapore and I’m using an Asus flagship rog router with no coverage issues. The lights are of latest software as well.
My experience thus far is that yeelight is rather unreliable. I had yet to use other smart light so far and thus am unsure if the standards of the other competitors. But my smart plugs from linksys and speakers from sonos on the same network and Google had rarely fail me. Maybe like 0.5 or 1% of the time. 1 failure out of 100 attempts is fair and good. Not 1 out of 3.
I’m being subjective here right?
And I do hope that I get a solution. I had invested a bit on those 34 smart light afterall

Hi, I want to know if these bulbs are online when the case happens, you can have a check from Yeelight applicaion.

There was a period like a month ago when for almosta week things didn’t work. I.e. some switches didn’t work, sensors disconnected… but it was obviously issue in the cloud. But apart from that, I really had no problems. Not to say there were NO problems, but only ones that I have created - i.e. had to use circiut braker and then some lights or sensors didn’t come online, but it was easily solved by again power-cycling only those lights. It is SLOW to access some things from 4G (when not connected to Wifi at home), but that is because I am using china server… Google voice control works for me 100%. I don’t remember ever failing. Sometimes it doesn’t understand me, but rarely, maybe because of my device naming…

Hi, I believe they are. One example and scenario that happens quite often is that,
-my manual electric switch button are on for my living room which consists of 4 yeelight
-the 4 are on off mode
-I pressed the mi smart switch or command via Google assistant
-only 3 out of 4 turns on, error on 1
-so I turn off and on the manual switch to ensure all lights are on
-after a while (maybe after my movie session and I am leaving the living room)
-I press the smart switch to turn off
-3 out of 4 turns off. 1 is left on… The one or two yeelights that are misbehaving can be randomly different. Not always that one or two.

I get a lot of such face palm moments daily like 1 out of 3 attempts. Sometimes more, sometimes one less

Hi, please create a group in Yeelight application and add these four yeelight in. Control the group from Yeelight application to see if they all work well (better use 4G network).

If yes, I think there’s something error with google home and smart switch, please provider your xiaomi account, we will take a look at the issue.

In the end, I made 1 last try before I threw the lights away.

I open the light housing, there was a connector inside. I disconnect and reconnected it a few times.

Strangely, the light started to work normally. Hence, I would say it was a hardware assembly issue.