Connection timeout issue

I have the current version, 1.4.2_0038
I’ve tried adding the bulb to my account and it still wouldn’t work.
It only ever works through the lixin account.

Got no idea, we use long account to test from our lab with version 1.4.2_0038, it works well.

can you please whitelist me ? I’ve added device named LightMichael my account id is 6227693512 - can’t see in the lixin the *56 firmware version yet.


Can you please reset password account I tried to connect but it says wrong pass.

Thanks in advance

Hi I try lixin account, but password incorrect. Please help

Hi, I have the same issue with the " Yeelight Meteorite LED Smart Dinner Pendant Lights". I can see the device and the processes goes as normal until 65% is reached. After that i always get the message of the connection timeout.

My ID is 1884514350 and I’m based in the UK using the recommended Germany server.

Any help on this would be greatly appreciated.

Thanks in advance

I think I’ve solved my problem. This is far from ideal but for the moment it worked so I decided to share it with you.

This is only for the specific problem when the DNS in your router/connection need to be changed but in my case as the router is own by my internet provider I couldn’t do that.

So for that specific problem my solution was.
1.- turn off my WiFi at home
2.- creat a hotspot point with another phone with same name and password than my home
3.- use my phone for the connection. In this case I didn’t have to but change the DNS is easier than with the router.
4.-connect the lamp with the normal process
5.- set everything up.
6.- turn off the hotspot
7.- turn on WiFi

et voilà all set.

I hope this helps others but as I said only for a very specific problem.


1 Like

Hi there,

i cant connect my Yeelight JIAOYUE 650 to my router. It is in the DHCP list from the router but at 100% it says connection timeout. I tried connecting via mobile hotspot but that doesnt work either. I use Germany as server.

My ID is 6163919629 and i already have one ceiling light connected where I did not have this problem. I tried to change DNS server etc.
The lixin login doesnt work any more password changed?

Can you help me please? How can i connect it? I am using the Yeelight App.

Hey can you reset the lixin password please?

Hi, having same issue with color bulb

My user is 6150779668

Can’t use the lixin user, can you guys fix it ?


Just got the password back, have a try.

thank you man! Solved it!!!

Thank you so much for the solution. I was at my wit’s end with this problem. Finally got it resolved by following your steps.

Could you please whitelist me too? my id is 1889145173

thanks a lot

p.s. user and pw not working

Anyone who can help me please?

connection timeout issue with desk lamp. could you please add my account 6150670852 to whitelist? thanks in advance

Hey, guys. Please can you help me?

Just bought two RGB bulbs (new version) and after updating to the last firmware that was available on Yeelight app, they are really unstable now. I’m using Mailand China as server, and already tried switching the DNS for I also chose my 2.4 GHz connection for the bulbs.

It’s really frustrating, because I received them (two units) by mail yesterday, and couldn’t enjoy them. They only worked for a couple of hours and then the connection issues began.

Oh, and I tried to login with the Lixin user, but there’s no firmware update there (says that my bulbs are already updated).

My account # is 6247097402.

Yeelight staff, please help me…

Thanks in advance!

My yeelight 2 has also stopped connecting to my phone. I’ve tried logging in with the eyeliner account but it says software up to date.

Please add me to the whitelist (MI ID: 1884293588) and how do I fix this problem?

Hello can you please allow the lights to go dimmer. You released a beta software that made the lights go dimmer than the current 1%. My ID is: 1826197431