Connection timeout issue

Which device do you have with connection timeout issue?

There is no whitelist to resolve the issue, which device do you have?

Please have a check if the lamp connects to your router first.

Hello, my device is led bulb 2 color.

Could you setup a hotspot with another phone and connect the bulb to it to see if it works? If not, I think there’s something problem with it, you can contact your retailer for a replacement.

Hey there,

Im having the same issue here.

Tried log in with yeelink account above but could not up date the firmware.
FYI; I choose mainland China server

My account is. 6216388831


Hello, so you can connect with yeelink account successfully, but not with your own account, right?
Which device do you have?

Pls add me to the whitelist, my id: 176691495

Hello, I just bought my Mi LED Desk Lamp but when I tried to connect it with the Mi Home app, it says connection timeout. :frowning: Please help me! Thank you!

ID: 6220102355

Hello! I followed the “connection timeout fix”. I used the account and successfully added my device (LED colour bulb) to that account. I also updated it to the latest firmware using the China server. However, when I tried to use my account to add the device, it doesn’t work. Help please. My account is 6226216577

Hello My account is 6227166971

Which device do you use?

Xiami Yeeligth bulb E27

Please have a check which firmware version do you use?

I have the current version, 1.4.2_0038
I’ve tried adding the bulb to my account and it still wouldn’t work.
It only ever works through the lixin account.

Got no idea, we use long account to test from our lab with version 1.4.2_0038, it works well.

can you please whitelist me ? I’ve added device named LightMichael my account id is 6227693512 - can’t see in the lixin the *56 firmware version yet.


Can you please reset password account I tried to connect but it says wrong pass.

Thanks in advance

Hi I try lixin account, but password incorrect. Please help

Hi, I have the same issue with the " Yeelight Meteorite LED Smart Dinner Pendant Lights". I can see the device and the processes goes as normal until 65% is reached. After that i always get the message of the connection timeout.

My ID is 1884514350 and I’m based in the UK using the recommended Germany server.

Any help on this would be greatly appreciated.

Thanks in advance

I think I’ve solved my problem. This is far from ideal but for the moment it worked so I decided to share it with you.

This is only for the specific problem when the DNS in your router/connection need to be changed but in my case as the router is own by my internet provider I couldn’t do that.

So for that specific problem my solution was.
1.- turn off my WiFi at home
2.- creat a hotspot point with another phone with same name and password than my home
3.- use my phone for the connection. In this case I didn’t have to but change the DNS is easier than with the router.
4.-connect the lamp with the normal process
5.- set everything up.
6.- turn off the hotspot
7.- turn on WiFi

et voilà all set.

I hope this helps others but as I said only for a very specific problem.


1 Like