Yeelight Striplight Connection Timed Out

Hi Team

A few days ago I changed the Internet service provider, after that I cannot connect the Yeelight lighstrip with the application in the phone, the router sees the Yeelight lighstrip, it is connected, the indicator lights up in blue and does not flash. I am using a NETIS WF2419E router.

from what I tried:

“1)Reset the lamp and then see if there’s AP named like “yeelink-light-***” in your phone’s wifi list? If yes, go to see Step 2; If no, it means there’s something wrong with the wifi module of your lamp;”

phone sees

“2) In the Yeelight / MiHome application, add the lamp you want to connect. Make sure your router does not have a special password symbol. If the connection is successful, congratulations, if not, go to step 3;”

the password consists only of numbers

plz help me. my mi account 1752619550

Could you have a try with changing your router’s DNS server to instead of using automatically allocation?

by default dns in the router is disabled%D0%91%D0%B5%D0%B7%D1%8B%D0%BC%D1%8F%D0%BD%D0%BD%D1%8B%D0%B9

If you turn it on, it shows this. where to enter

DDNS has nothing to do with your DNS server. That is to set your outside adress. You need to find where to specify DNS server (not DDNS!!!), probably somewhere in settings for internet.

Someone help me?