Yeelight cannot be set to White via Google Home

Since the latest update to my Yeelight Lightstrip - version 1.4.2_0049 I am unable to set the lightstrip to White via Google Home.

I can set the strip to white through the Yeelight app fine so I assume there is a bug between the communication of Yeelight and Google Home.

Is this being worked on?

Lightstrip V2 ?

Hi same here. V2 strip, 1.4.2_0049. Google home don’t understand white. However it will turn white when asked to change colour to grey. Needs a a fix

My problem is, if I select ‘Gold’ for example in the Google Home app, the colors of the bulbs will turn into a far more yellow color, which can’t be called gold. This is just one of the colors that I can name right now, but I believe there are a few more colors not fully functional. The more ‘standard’ colors just work fine. This goes for the Yeelight Bulb V2. The LED strip seems to handle gold pretty good.

How can I tell which version?

Hi everyone,

I just fixed them. please try sync devices, by the way, strip V2 not support color temperature yet, so the white color looks like a bit yellow.


This is still not fixed.

I got it, 1.4.2_0049 this is strip v1 version, will be fix in 1.4.2_0050 version, please wait for firmware release.