YeeLight Color can't connect to router

Yeelight color setup issues.
In my house it didn’t work.
Tried the following, nothing worked.

  1. I’m on 220v, 2.4 wifi network.
  2. Tried to connect using my iPhone and Android phones.
  3. Tried to connect using MiHome and YeeLight apps.
  4. Tried with German, Singapore and China servers.

Went to a different house, setup worked like a charm.
In my router settings I don’t see the light in the DHCP list, can I add it manually to the router or change something in the router settings?


MI ID - 1906178643

What’s your router’s model? Any log you could find on your router?

i am having the same problem asus n-16 modem is also working but asus n19 rooter does not work. WAN DHPC not connecting. I tried all of them DNS is not working for server :frowning:

any news from this topic? I have same problem here, I have removed the device from the app. then i wanted to reconnect it, but it stopped at loading 25% and never reconnected. that really make me mad