Yeelight RGV Keeps Losing WiFi


#21

It seems reasonable to suspect an issue between Yeelight devices and certain routers based on forum responses. Regardless of whether the responsibility is with the router manufacturer or not, does that mean there is a list of routers that have been confirmed to work whether officially or unofficially?

For the record, I have been experiencing issues with D-Link and TP-Link routers. I even have tried a Xiaomi Wifi Repeater 2 but, proving that signal strength is not the issue, the Yeelights often connect directly to the router even though the repeater is physically located halfway between.

I’ve thrown time and money at this already. If someone knows the router I should be using then that will be my last throw of the dice to fix this.

Cheers,

Dave


#22

Unfortunately, this is the problem with how this issue is treated on the Yeelight forums.

A number of issues:

  1. The forums are next to useless, because a long time problem like this just ends up being hundreds of small threads per instance of the problem, most of which are quickly blamed on the customer’s router

  2. If you have a dedicated thread like I have tried to maintain here, you need to keep it active, or it just falls off the forums page. Because there’s a limit to how many times I can post in a row, I have to wait until others comment.

I don’t believe the issue will ever be solved and I don’t know why people believe that the fact that they bought a new router and it suddenly worked helps anybody else. Those who post that they have found a new router have not mentioned what router it is that is compatible, just that buying a new one (I am guessing not the same device) fixed their issue. Sometimes they will tell you they bought a more expensive one which I suppose is meant to help narrow down candidates but given more expensive is relative it does not really help either.

In all cases, including those cases where forum participants speculate that it is to do with “too many devices” on wifi or whatever else, the one key question is never answered: why is it only Yeelights affected? These are not high bandwidth devices. They should not be in a position to fall off the network and never come back.

All I can hope is that more affected users see this thread and continue to post, so that Yeelight take this issue seriously. I also hope that those who are blaming it on the router despite the points above could then at least offer some advice on which make and model worked for them so we can correlate a list of routers that work with the broken Yeelight wifi handling.

I feel confident in calling it such, because I have not had this issue with any other device, and I have smart lights from 2 other vendors in addition to my Yeelights, so to me it is quite clear where the problem lies.


#23

Thanks.

I’ll be taking everything out in the new year then. It’s a real pain because I’ve fed YeeLight Strips through false walls for under cupboard kitchen lights.

Buy cheap, buy twice.

Thanks for your help though.


#24

I’ve just seen that I can buy a Xiaomi router for £15.

On one hand I don’t want to throw more good money after bad but, on the other, it would be hard for anyone on here to blame a Xiaomi router. My intention would be to set a small DHCP range with address reservations for the Yeelights so that they effectively had their own subnet straight to my DSL modem. All other devices will remain on another subnet.

The only thing that is stopping me is that I am not optimistic that this will fix it and so it is just more time and money to prove a point.


#25

That is a good plan and it might work fine, only one issue though - I think you might have problems with MUSIC mode if you want to access Yeelights from another subnet. This is somethin I have tried first (makes sense to have different subnet for Yeelights) but music mode was not working (well). So I have everything on one subnet but another router and IP reservations (from x.x.x.200 upward is reserved for smart home)


#26

You do you.

I am keeping this alive for those of us who won’t buy a Xiaomi AP just to be compatible with Xiaomi wifi products, however. It’s an interoperable protocol and any failure to interoperate is a failure regardless of the workaround, so whilst I wish you well in the endeavour it won’t change the outcome for others.

It may however end up being the first verified working platform if you’d be as kind as to share your experience with us.


#27

I’ll not be bothering with another router as further investigations have eliminated this as a cause to my mind. I am sure that everyone here that has suggested routers as being the issue has been doing so in good faith but I am confident that is not the issue, at least for me. I’ll outline how I reached this conclusion below for the community.

My smart device problem has been getting worse of late so that, even though the issues have been intermittent and inconsistent, I had reached the point where there would always be at least one issue somewhere. My example is probably more extreme than most because I have over 50 devices, 12 of which are Yeelights. Always having some problem or other has at least now enabled me to troubleshoot further though.

The issues always appeared to be with Yeelight products showing as offline in the app. Other devices from other manufacturers were starting to be affected in that they would sometimes miss IFTTT events but would always be there in their respective apps. This wrongly led me to suspect general issues with my network and so I had been trying different network components over the last few weeks yet the problem persisted.

Yesterday, I thought I’d reserve addresses so that all my Yeelight products were allocated addresses next to each other. To my surprise, I found that a number of the Yeelight devices were using IP addresses that were also claimed by other manufacturers’ devices. This was a Eureka moment because all of the symptoms I had experienced could have been caused by duplicate IPs. I continued to reserve addresses and found that some Yeelight devices would not use the new range even though the leases must have expired on the addresses they were using. Restarting everything (including the the router with DHCP enabled, my wireless access points and the wifi extenders to force the issue) did not make the difference it should have for these suspect Yeelights although it did work for other manufacturer’s devices and some Yeelights.

Next, I disabled DHCP on my Belkin router and replaced with a TP-Link router. I left all Yeelights off while setting this up and configured the TP-Link router with the DHCP reservations. I then restarted the Yeelights one by one and they were all correctly allocated my chosen IP addresses for each of them. All looked good in the app and I was feeling unduly smug. Everything from all manufacturers started to work perfectly and consistently. I at last had regained a working Smart Home.

Everything worked perfectly until this morning that is. I now find the same 4 suspect Yeelight devices are intermittently showing as offline in the app. Everything else by every other manufacturer is working.

I have confirmed that the suspect devices are definitely retaining the correct IP address and I still have no duplicate IP addresses which is something. Pinging the suspect devices though shows intermittent dropped packets and responses from 2ms to 400ms. The Wifi strength is definitely good and there is no channel conflict with neighbours (confirmed using various apps on my mobile but also evident with the Xiaomi Wifi Range Extenders currently placed next to the Yeelights remaining connected throughout and reporting as healthy in the Yeelight app).

I have now found that switching off the suspect Yeelights for an extended period (say 30mins) makes them reliable at first but leaving them on gradually degrades their Wifi reliability. I suspect this may have been the reason the DHCP was going awry for me before (with them requesting an address but not successfully responding with an ack or maybe not successfully renewing fully). This may also explain why some other users have found changing routers has helped (maybe the new router’s DHCP is more tolerant or maybe the act of the changeover and forced reset fixes things for them in the same way it did for me very temporarily).

Regardless of the DHCP challenges, my Yeelight failures clearly cannot be resolved by changing my router. I can say this with absolute confidence because I can test the local device connectivity with pings even with my router turned off. The suspect devices and my laptop are both connected to the same Xiaomi Wifi Extender and both in the same local subnet so that there is no router involved in the ping and I still see a gradually degrading success rate. I have tried different wireless access points for the extenders just to eliminate that as a possibility and this makes no difference.

I am in the situation where I have some Yeelights that are rock solid and others (exactly the same model) are unreliable even though they are all connected to the same environment on the same account. With them all running the same firmware, my only conclusion is that issue is actually a hardware fault and I will be removing the suspect devices but keeping my other Yeelights. If this is the same for others that have been reporting similar unreliability then it may be a general quality-control issue with the hardware. It may be others have other issues though of course - this has just been my experience.


#28

Yes, looks like hardware fault… very nice and detailed reading :slight_smile:


#29

Glad you have found the issue you were facing, @DarthVoda.

In the meantime, I’ll keep this thread open for those of us who are not experiencing the problem described, but instead the intermittent loss of wifi connectivity entirely as identified by the fact that the devices fail to respond to any network traffic on their previously assigned IP address and that their MAC address no longer appears as a connected station, until the bulb is powered off and on again.


#30

Just to add another wrinkle to this: my Yeelight bulb will respond to the app and to LAN TCP calls made from a Python program according to the LAN specification. But intermittently it fails to respond to SSDP discovery requests as I reported in Intermittent responses to SSDP requests. Even at the times it fails to respond to SSDP requests it still responds to the app and to direct TCP requests. I’m using a Linksys router, and I have no problems with any other devices at any times.

I have been trying to build a Mycroft (like Alexa, only open source) digital assistant skill for the Yeelight bulbs. The failure of SSDP discovery to work means that I can only post it with a rider “intermittently breaks due to problems with discovery unresolved by Yeelight” and that isn’t very satisfactory!


#31

I thought I had a problem locally, but apparently I’m not alone. Yeelight bulb very often loses the network. For last year I had three different routers and all connected devices (except Yeelight bulb) worked stably, including Xiaomi Vacuum, which regularly cleans the entire apartment (and it never lost network connection). At the same time, the Yeelight bulb is a meter away from the router and has regular problems…

Basically, the loss of the network occurs after a possible turn off the light in the apartment (which happens in the winter). At the same time, neither restarting the router, nor turning off and turning on the Yeelight bulb does not help, only a full reset. Today, the loss of the network was three times and this is clearly annoying: (