Issues Scene with google home

i’m having a hell of problems with google home and yeelight.
Since early this morning I’ve tried to change servers (China, Germany) jumping from one to another to try to make work Yeelight and Mi Home with Google Home, now when I ask google to ativate a scene it looks like it is confused between 4 scene (instead of just one)!
I mean I suppose that even if I’ve canceled all the devices from the differents servers and keep’em in the end only in the Yeelight German servers, Google Home still sees 4 scenes lost in all the servers.
Same happens when I sk to turn off (e.g.) the bed lighstrip, google says “i dont know which bed lightstrip you’d like to turn off” even if in the Yeelight App and in the Google Home app ther’s only one Bed Lighstrip.
How can I Manage this?
Thank you

Please try say: “Okay Google, sync devices”

Hello @Yusure, I’ve done it multiple time.
Google saiys that she’s having problem with syncing Mi home even if mi home is not even linked anymore to my Google.
And it synced 36 lights from Yeelight even if I have “only”. 15 of them. This is my ID: 1649997788
A bunch of users are experiencing this problem, please refer to this topic:

Google home problem. Am i the only one?

Don’t both use Mi Home and Yeelight on GoogleHome app.

It doesn’t look like a solution… But I’ll take it as it was.
The problem is still the same: currently my Mihome it’s not linked to Google home but if I ask to turn off a specific light, Google says the she doesn’t know which specific light I’d like to turn on, because she sees duplicates of the specific lights from previous link between Yeelight and mihome to Google home.
Thank you

Please change the device nickname on GoogleHome app, have a try.

Yes is what I’ve done for now, renamed all my 15 lights and alltly 10 scenes… But it’s not a real solution, it’s a workaround, an annoying one actually.
And the thing that Google sees 36 Yeelight is still there.
No one have a clue about this? Why Yeelight and mi home are kept in memory of the Google home even when they are unlinked, delated, departed and so on…?
It happens only with Yeelight and MiHome, because I have a TP Link plug and Google only sees one even after un linking and relinking it, not forcing me to change everytime name of the plug.
Thank you