Led Color Bulb V2 Issue "CONNECTION TIMED OUT"

So a couple of weeks ago I bought from gearbest this device, and got home today so I decided to set it up but suddenly when the device was supossed to connect to the router and update pop up the Error message “Connection timed out”. I tried everything, set region server to china, singapur, and every other server I could to, I reset the router to default settings and changed the DNS to but none of them worked, I have even tried with two different Xiaomi Smartphones, Mi 5s and Mi 8 but both got the same error message. I would really aprecciete your help guys. Thank you.

please double check if input voltage match the requirement.

I mean the yeelight works well when I plug it and turns on but it doesn´t connect to my router somehow so i can´t add it as a device either in yeelight app or Mi Home

When the error message pop up, please check if the bulb has connected to your router(check the dhcp list via the web console of your router) .

Exactly, when it tries to connect to the router it appears into the dhcp list but it doesn´t assing an IP to the device, then when the message error pop up it disappear in the list

  1. what’s your router model?

  2. please try to start a hotspot with your phone with mobile network, then connect your bulb to that hotspot with another phone.

1- My router model is: ZTE ZXHN F680
2- Yes, I tried with a hotspot and it works but once i dissconect it to the hotspot I can’t control it anymore so I guess the problem is on my router.But I need to connect it to the router, otherwise will be useless being in hotspot 24/7

We have received similar issue report related with ZTE GPON routers, but those routers are special designed for ISP in certain region, we can’t get that router for testing. Did you get it from your ISP?

Is there some kind of whitelist enabled on your router that deny any other endpoint to connect?

I got it from my ISP as you said, I’ve read in forums that people normally have issues with this Router, and no, there isnt’t a whitelist that denies any device. I tried creating a hotspost with the same SSID and password of my router, then turning off the router and making all the process connected with the hotspot then turn on the router and instantly turnin off the hotspot and somehow works, but once I swich off the bulb it disconnects from the router and I have to do same process again and again. So the problem it´s definitly on the router, if you can help me out I would aprecciate it. Thanks for your time I´ll wait for further instructions.

We have tried to purchase that kind of router to test, but unfortunately, as I have mentioned above, that router was designed for certain ISP, we can’t get it from open market.

But you could buy another router to connect to that router’s LAN port as layer-2 network, and try to connect your bulb to that new router, don’t need to be a powerful one.

I think that gearbest has some faulty bulbs. I bought one last month and I had the same problem. Then I bought another one from Amazon and it works without problems. Ask to gearbest to change your bulb. There is no solution for this problem. It doesn’t depend on your ISP, but on the bulb.