Yeelight LED strip not connecting - issue - Connection timeout

Hi there, my yeelight account id is 5191512458
I am not able to connect either my android or my iphone to yeelight led strip. It gives me the error,” connection time out” on my android phone at 100% process completion and just errors out on my iphone at 25% process completion.

I have changed my router DNS to google DNS and the yeelight is visible as connected in its DHCP list.

I have also tried to connect the yeelight to my phone hotspot but to no success.

I have tried singapore server and china server but no success.

Any help will be appreciated on how I can start using these lights

Reading through the forums, I think the resolution of accessing with the following ID will work :

Password yeelink1234

Unfortunately, yeelink app is telling me the password has been changed. Can you please tell me he new password for the account

Fixed, please have a try again.

Password: yeelink1234

Hi. I am trying to use the login and password to update my firmware. Can you please help me as the password has been changed again. Thank you so much