Yeelight color bulb won't connect anymore

I have 2 Yeelight color bulbs that I got a few months ago and they have been working perfectly until yesterday. I saw that there was a firmware update so I updated and then my bulbs were unresponsive and just said “offline” in the app. I couldn’t get them to work again so I decided to reset them. After updating and resetting them, I cannot reconnect them to the app. I have tried everything. I set my router to I reset them countless times. My router password doesn’t have any special characters. The only way that the bulbs can connect is if I remove the password to my WIFI network which I don’t want to do. The lights will show up in the DHCP but every time I try to connect them in the app it says “connection timed out”.

I am getting very frustrated with this and I have been trying to solve this for hours now and still no luck. I am really regretting updating the firmware and I wish I had just coughed up the extra money to get the LifX bulbs instead.

Any help would be greatly appreciated.