Mi Ceiling Light wall switch 3 sequence cannot be changed

Hello, i installed my Mi Ceiling Light and struggle to deactivate the 3 modes that cycles through when you turn it on the old fashioned way, using the wall switch.

As I am the only in my family that uses the app, other family members are annoyed by this feature.
First, i tried with yeelight app and found that i’m missing the key options that are under Default state

Mitigation: I tried switching to Mainland China(i was on Singapore). No luck, the options never appeared.

Then i tried pairing the ceiling light with Mi Home, can’t find a solution here either.
Mitigation: Best option in Mi Home is the fact that you can edit those 3 sequences. But as stated in Cannot find "Set default light" , the presence of a night mode that cannot be deleted renders this option ineffective.

I re-paired the ceiling with yeelight app as the integration of mihome with google home is faulty. I tried the solution mentioned in the thread above(waiting for more than 10 sec to turn on again the light):
Using the wall switch, i turned on the light.(first sequence, warm light)
Turned off.
Waited way more than 10 seconds.
Turned ceiling light on again using the wall switch. At this point, it should have remained on the first sequence the warm light, but no, it moved to the second sequence, the cold light.
Turned off the light.
Waited a minute.
Turned on the light.
The ceiling light moved to third sequence, the night light…

So for me, the issue is still there and my family is nagging me to fix this, as if i’m a wizard or something.

Please help me with this situation, the light should function as a standard light too, but i’m unable to use it “the simple way” right now.

Thank you very much for your support.

Hello, You need to do like this.

Turn on the light more than 5 seconds. Then turn off.

Turn on the light again. It would be remained on the first sequence the warm light

Hello, Thank you for your answer.
I tried this, it does not work, i waited longer than 5 sec. I even waited 1 minute, it does not remain on the first sequence, it cycles through the preset (warm, cold, night)

Hi, I want to confirm. You need to turn on more than 5 seconds, not turn off more than 5 seconds.

Thanks! Wizardry!
This was very helpful. :smiley:

:smiley: