Yeelight LED bulb "connection timed out"

Is anybody else having this problem? Last time it happened I had to change the server, but now none of them works. I am using a different ISP and router since last week, lamp is not shown in DHCP, so I fixed an IP. Also I disabled firewall, created a DMZ, etc, nothing works.

Could anybody please tell me if it is again a global problem?

Finally I solved! But for how long?

I’ve change so many configs that I don’t which one is the one who worked. If somebody is having this problem, ask me and I tell what I did. I don’t recommend yeelight anymore. I going to sell my 2 lamps and buy that one that works with a remote control, without asking me my router password.

Same thing with bedside lamps v1 too

I just set up my second lamp after lots of tries.

In the past I used only the yeelight app and it used to work like a charm, now I have to use the mi home and put it in the auto start and then scan, and then configure manually and choose the lamp wifi and than this an that and try again, and reset, and change server, and try and try… for god sake!

Try to disable your 5GHz wifi on your router (not sure if it is really necessary) and set the google DNS 8.8.8.8 and to this thing that I mentioned above. It looks easy now but I spent a lot of time on this shit.