Yeelight Ceiling light connection problem

Hi all,

Have a problem with my Yeelight Ceiling Light. I tried to update it to the latest firmware, after that my lamp can’t connect to either the remote or smartphone. I rebooted it several times, but still got nothing. I checked the Wi-Fi settings - seems like it’s alright there.

I think i really tried everything to make it work as usual, and now i need your help. Is there any way to roll back to the previous firmware where everything was working?

My MI ID: 4163652720


Hi,it maybe router compatibility issue。
Please power off the router,reset the light,then use your phone’s hotspot and MIhome app,this can connect to the China server。
After that I’ill add the device to the whitelist,you should first upgrade to 1.6.6_xxxx,then you can use Yeelight app and switch back to other server。


I tried to do exactly as you told, but Mihome app can’t find the lamp even with the mobile hotspot. I switched the server to China, but no luck either. The lamp just doesn’t respond to any of my actions.

Hi, the light is already connected to China server。you can upgrade the firmware now。