Yeelight bulbs, can't get to connect

these are the ones I bought, not sure which (if it particularly matters?) to choose in the phone app setup for these(?), but haven’t been able to get any of them to connect yet. I’ve reset them numerous times, they only show up in my phones wifi for a short time before disappearing again. I’ve tried changing various settings in my router setup (Netgear WNR3500Lv2 with latest firmware V1.2.0.54_50.0.94) even took the individual mac addresses off the bulbs and tried manually entering them but they never show up as connecting…

using iphone 6s software version 12.4.1

Well I guess I’m just going to have to try and return them, not any sense in keeping them as they won’t do what they’re sold as. Now i understand why all the good reviews of the Philips Hue system even though it is so much more costly. Doesn’t really matter if somethings cheaper if they can’t be made to work. - I’ve wasted a weekend fighting with them trying to somehow get them to connect and nothing’s worked.