Time out in all my yeelights bulbs after they were working fine


I’ll try the pings when arrive at home in a few hours. I live in europe.


I didn’t find and device under your account. Please double check which server did you select in Yeelight app.


Please check again, now it’s ok I think. China server.


I didn’t find any device. Please double check if this is your account.


yes, this is my account.

With “device” you mean the bulbs? I had three bulbs connected well, a week ago more or less, then I lost the connection with the bulbs and I tried reset them. So, right now I don’t have any device connect because of the time out error.

The pings worked well, btw. The results:


Please try to connect your device to mainland china server again.

Just try once, and let me know the detail time, we will check log from backend.

BTW, if you run into Connection Timeout error again, please double check if the bulb has connected to your router.


I’ve just tried connect to mindland China server. At 21:26 cst. And yes, the bulb has connected to my router.


OK. We will look into it and let you know.



We have been working on this case.

No progress so far. Stay tuned!


Did you try that in the same network as that bulb connected?


Yes, the same network.


Which country do you resident?




Try the latest beta version of Yeelight from Google Play, which supports German server.


What’s your router model? Did you setup some kind of firewall features on your router?


It’s a ZTE F680, and don’t remember in this moment the security but one of the test that I did, it was based on disable all security.

There’s nothing into logs? So, the bulbs aren’t being able to connect to the server?


Find nothing from server log.

Try German server and let me know.


It works! On german server. thanks so much.


Glad to know it works.


Hi, despite of the bulbs already work fine, I wanted to know what was the real problem with the connectivity. So, after investigated a bit more I found the problem, and the winner is: the default DNS server.

SOLUTION: really easy, just change the default DNS server in the router to the google server ( Once bulb configuration is completed you can restore the original DNS server.

Maybe this is helpfully for more people with similar problems.