[SOLVED] Yeelight Smart LED Ceiling Light - app works great until

Yeelight Smart LED Ceiling Light - app works great until i turn off the light from the well switch,
when i do that (turn off and on), i can’t connect the light from the app, it’s show as “offline”,
and when i press the “refresh” it’s suggested to check the WIFI connection, Device is power on…
i don’t know what to do any more. the only way for me to connect again is by RESET and make the binding again.
app version is: 2.3.13
app local set to: Singapore
my device is: htc m8, OS: Android 6
my router: first was D-Link DSL-G256DG and now order new one: Linksys WRT3200ACM AC3200


When you cut the power, you have to wait about 1 minute to see it’s online in App. The device needs some time to connect to router and contact with the server.

i give it more then a minute, 30 minutes, 1 hour… still offline in the app.

Could you share your firmware version with us? Also, how many ceiling lights do you have?

firmware version is: 1.4.0_130
i have one ceiling lights.
i took a video of the problem, video start from the RESET point:

Your firmware is too old, please update it firstly and see if the issue still exists.

checking under firmware update in the app; say it’s the last firmware

where can i get update and how to do it?

Could you switch to China mainland server and do the update? New firmware is not released on Singapore server yet.

switched to China mainland and upgrade firmware is now 1.4.3_155
i ran some testes and it’s looks like everything is working perfect.
app works in WAN connection and in Cellular connection in China server and in Singapore, firmware upgrade did the trick. i stick to China server for now.
thank you, @weiwei,

No problem, there are some bugs in old firmware :relaxed:
We will release the latest firmware to Singapore server as soon as possible.