[SOLVED] Does anyone else have trouble with the Color bulbs dropping packets?


#1

Hello,
I recently got 3 of the Yeelight Color Bulbs. Set them up without a problem. Was able to switch them off, change color, without any problem.
A few hours later, I press “All Off”, but only 1 turns off. A second later the second turns off. The third light stay on. I press “All Off” a few more times, and the third light turns off.
Pressing “All On”, only 1 light turns on, but the rest stay off. Pressing “All On” a few times, and the rest turn on.

I’m doing a constant ping to the IP addresses of the bulbs, and I seem to be getting 60% packet loss. Rebooting the router fixes the issue, but only for an hour or so. Turning off the bulbs and back on rarely fixes the connection issue.

Is it just me? Did I get 3 bad bulbs? They’re all on the latest 1.4.1_52 firmware, so I don’t know what I’m doing wrong.

Any help is appreciated. Thank you in advance


#2

Is your router very old? How many devices have connected to your router?


#3

Linksys WRT1900ACS, and 12 devices (including the 3 bulbs).


#4

Fixed the issue by installing another WiFi router, specifically for the bulbs. DHCP is still on the main router.


#5

Hello @miroppb, I’m having same problems when I create groups. I’m using the router that my internet company provided me. Do you think that if I change router my bulbs will work well? Not sure what do you wanna mean that you are using 2 routers. Could you give me a little bit more information as I’m getting crazy?

Thanks in advance.


#6

I had another router that I just had lying around. Had this brilliant idea to use it to have a separate WiFi network, just for the bulbs. My current setup:

Modem -> Main Router (WiFi and DHCP) -> Second Router (WiFi specifically for the bulbs, no DHCP)(Ethernet plugged into port1, IP is on the same subnet)

Simple networking. Let me know if you need any help configuring this setup.


#7

I’m going to buy a new router to see if I can fix the problems doing the same than you. I will tell you in a week!

Many thanks.


#8

Hey @miroppb I bought a new TP-Link router.
With this router I can create a guest user network.

Should I have to create this guest network and connect the gateway and bulbs to it?

Gateway and bulbs have to be in the same wifi right?

And last question, why to deactivate DHCP on bulbs?

Many thanks for your help!


#9

You don’t have to make a guest network, just a separate WiFi network.
I don’t think the bulbs have to be on the same network, but you’ll have to pair with them, so it helps.
The reason DHCP is disabled on my second router, is because its linked to my first router, that does have DHCP enabled.
Hope this helps.


#10

I have Xiaomi Mi Router 3, i just enabled Static DHCP today for all the wifi devices.
I will write feedback in 2-3 days…


#11

What is Static DHCP? Never heard of it…

EDIT: Ah, DHCP Reservation?


#12

DHCP reservation or Static IP adress :slight_smile: