RGB Bulb disconnects from wifi


#1

Hello guys,

I have received Yeelight rgb bulb yesterday and ever since I am having trouble to properly control it.
My bulb is losing wifi connection after 10 - 15 minutes. After that it becomes invisible to the router and the phone.
Then I have to turn it off manually and wait for couple of hours to be able to reconnect to it again. And of course reconnection process requires reseting.
I am using Android 7.0, app is the latest version available in the Play Store and firmware on the bulb is also up to date.
Also my Xiaomi router is less then 2 meters away from the bulb.
Is there any solution for this?
Thank you.


#2

Have you checked if the device is also offline in MiHome application?
And when the device shows offline in Yeelight, could you help try with “Turn All On/Off” to see if it works?


#3

Yes, device is also Offline in MiHome app.
And turning All On/Off does not work.


#4

So it seems the bulb is offline. What route do you use? Could you have a test setup a hotspots with another phone and connect to it to see if the bulb goes offline in 20mins.


#5

I mentioned this problem in my topic. You can take a look. Somehow it’s related to your phone. I changed my phone and the “offline” problem resolved.


#6

I read your post yesterday and I have tried with a different phone but it still loses connection. I currently use Moto G4 but yesterday I tried with Redmi Note 3.
The funny thing is that the bulb disconnects from the wifi only if the light is on. I have it connected this morning and I turned the light off. It’s been about 3 hours since then and the bulb is still connected to my wifi.


#7

I use Xiaomi Router Mini. Few days ago I have tried with a different router and it was still going offline.
As I just wrote if I connect the bulb and turn it off it will stay connected. But if the light is on then it goes offline.


#8

Could you post a picture where is your bulb plugged? It seems it has a bad elimination of heat.


#9

Please see the photo in the link below.
I also suspect that heat might be the problem. And have tried to plug it in a completely open lamp. It also stopped working after about 15 minutes.
Yesterday even though it was off and warm to the touch it lost wifi connection after few hours.


#10

In the end buying Yeelight bulb turned to be a waste of money and time.
Today I bought sonoff which I connect to the lamp with Yeelight bulb to at least get some control of the bulb.
Now I can set it to turn on and off at a specific time.


#11

Hi, I use to have this problem. For me i just go to the wifi setting and set the wifi connection channel from auto to channel 11. It is working well for me till now.


#12

My wifi is at channel 1. Is there something special about channel 11?


#13

Well maybe there is some crosstalk but I have let yeelight staff know about this problem


#14

The bulb only supports 2.4ghz, so if you have a mix wifi with 2.4g and 5g, please cancel it and set a separate 2.4g wifi.


#15

Of course. I’ve been only using it on 2.4g