No Connection to bulp :-(

I bought a Yeelight bulp and I try to connect it to my Wifi.
But I’m not successful!
I tried the Yeelight App but also the Mi Home.
I tried it with several Wifis in my house.
The lamp is found but, it is connecting to he lamp via Wifi, than to the Wfi again. But when reaching 100% I get the message "connection time out. Check current Network and scan again.
I reset the bulp serveral (!!) times
I am living in germany

I tried to connect via my mobile directly (not over Wifi/Router). There a connection was possible,

Has somebody an idea how to fix the problem?


Which server did you choose? China Mainland or Singapore? After connection fail, can you see the bulb in your DHCP client list on your router?
If you can see bulb on your router, please try to use your phone as a hotspot and connect the bulb through it.

Hello weiwei,

  • I tried it with both - China and singapore.
  • No. The bulp is not listed in my dhcp-List (Router).

Is it a problem of ports? When I connect the bulp over a Hotspot over another Mobile it works. When I do the same of the connection of my router it doesn’t!

Regards Dorian

Should be caused by router’s compatibility issue. If your router is Apple, please update the firmware and then it should be good. If your router is some very old and unusual brand, please check the settings or logs.

I bought a yeelight color LED light.
I can connect it by iphone 6 with

  1. my ipad hotspot
  2. my home router (Netgear) and home broadband ISP using either guest network or normal network.
  3. Aruba access point through my home broadband ISP.
    However, when I connect the aruba access point to my office broadband ISP, it did not work.

How can I solve this problem?

Please check if it can connect to your office router. If yes, please make sure your IT doesn’t block the traffic.

Actually my office has no wireless router. I have tried to plug my AP in my office network. However, it failed. Do you mean I should use my office computer to ping the mi server(like the post before) to see if my office network blocks the mi server?
Should I change the DNS to
Is it common for ISP to block mi server by firewall?

First, you have to make sure the lamp is connecting to your router. Then, you can check if the traffic is blocked by firewall UDP port 8053, TCP port 80.

How can i know if the lamp is connecting to my router?

Login to your router’s console and check the DHCP client list.

How can I check if the traffic is blocked by firewall UDP port 8053, TCP port 80?
Can I check the connection using windows cmd? Like ping, netstat or telnet?

No, you need to check with your IT team or the ISP.

When the bulb connect to in the DHCP client list do you know what the first few letters of the mac address are? Does ti populate a host name?

Hostname starts with “yeelink-light-xxx”.