My broken yeelight led

Hi friends.
My 2 yeelights after upgrade can’t connect. When I set connect yeelight I see:
Device is connecting server (!) and error (can’t connect to cloud service)
How I can recover?

Could you try to use your smartphone as AP to try the connection? Or you can check the issue step by step, first, logon to your router and check whether it connects to your router successfully.

My router, my phones (android & iOS) absolutely works fine.
I’m not stupid & I know how it works😉
After upgrade firmware Yeelight can’t connect to server & can’t connect to cloud service & I can’t connecting my Yeelight to my smartphone. I have 2 Yeelight’s with defects.

Could you use your smart phone as AP and connect the bulb through it instead of your router? This is to help debug whether it’s caused by your ISP or network issue.
You can also provide your account (xiaomi ID), so we can check the log on our server.

If I use my smartphone as AP Yeelight can’t connect.
My Xiaomi ID 1615824703

We will check the server side on next Monday since this week is national vacation in China.

Hello, if it could help, same issue for me.
2 bulb, the first was ok before the update but doesn’t work since the update.
The second works very well but I’ve not done the update.

My Xiaomi Account id : 107165272

We will check the issue soon, sorry for the inconvenience!

Is this the first time your upgrade your firmware? Do you have the chance to remember the firmware version before you did the upgrade? e.g. 1.2.4_xx

I have same products and iOS device. I am face to same problem. I upgraded firmware and then my connection is broken now. I restarted several times but I got same result. Please help!

1 Like

First time, firmware may be 1.2.4_x

Hi all dear yeelight users who face the offline issue,

Could you do us a favor to help debug the problem? Please logon to your router and check whether the bulb has connected to the router (check if the bulb is in the DHCP client list and ping it if possible). So we can know if it’s caused by firmware issue or network issue.

Thanks for your understanding and support!!

In my router;

yeelink-light-mono1_miio13675302 192.168.2.96 f0:b4:29:95:b5:47 VLAN 1

Thanks! So your bulb can connect to the router, but can’t connect to the cloud, that’s very helpful, thank you!

So What should we do?

Could you help ping “ot.io.mi.com” and see if it’s reachable. It’s the cloud server’s domain name.

Pinging ot.io.mi.com [58.83.200.12] with 32 bytes of data:
Reply from 58.83.200.12: bytes=32 time=604ms TTL=41
Reply from 58.83.200.12: bytes=32 time=315ms TTL=41
Reply from 58.83.200.12: bytes=32 time=317ms TTL=41
Reply from 58.83.200.12: bytes=32 time=313ms TTL=41

Ping statistics for 58.83.200.12:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 313ms, Maximum = 604ms, Average = 387ms

It is done. I just opened Yeelight app and it works!

What have you done to make it works?

Nothing, I just ping ot.io.mi.com and opened yeelight app. It works. I don’t understand What I have done.