Mi gateway on Singapore server


#713

I have the same issue, cannot even reset the hub by pressing the button 5 times. Not even from the China server…

edit: I think it might be the “accidental deletion” option being enabled, however I cannot see it anymore in the MiHome app so I cant remove it…


#714

I haven’t enable the accidental deletion option. I hope to be able to reset the device if I decide to move to China Server

ps: to reset the gateway long press the button for five seconds, not five times…


#715

hi, yes I meant 5 seconds :smiley:

I have read that the gateway can also be fully hard reset by using a pin in a hole in the front face… this should remove all software updates and yield it to stock: maybe this way I can reset it, because I think I did enable the accidental delete protection.


#716

never heard of this. waiting for your feedback


#717

oh no, just realized the instructions were for a different mihome system (https://mihome4u.co.uk/troubleshooting).

bummer…


#718

Shame…
Luckily, I had no problems to reset my gateway and move all my devices to Mainland China server.
The story of Singapore server is over for me.


#719

@psybill same problem here… before the last update, I can login on singapore server without any problem… with the last update, I can not see anymore a part of my equipment… everything is still working but I can not add a new sensor or modify the old routine involving these “can’t be seen” sensors…


#720

I tried older versions but it didn’t work. It happened at the same time with the release of the latest version, its a server side change though.


#721

Xiaomi… what a joke… i wanted to buy the Mi Mix 2s but just because i am so frustrated with their fake promishes, i went for another phone. I said it before, but I wish that Yeelight had their own buttons etc without the need of the Xiaomi gateway.

For the record i changed my phone about 10 days ago and now i cant access the gateway anymore (singapore) although i havent tried any of the old workarounds since i had a renovation in my house and i still dont even have the sensors fixed in the right places. If Alexa works ok with the skill in Mainland China then i will revert back to China even if everything becomes slower but in the first chance that another solution, button etc finaly works for yeelight in the future, then Xiaomi and their gateway is over for me…


#722

Hi, need your advice, I tried many time to link SG server, only limited devices are seen like what you have mentioned, only the regular gateway and not the AC companion (both round and square version) and many other devices are not shown as compare to CN server.

And when I use CN server, I could not get it to link to Google Home, Google home said link success but MiHome has never shown up as linked Device. Tried many times.

So I thought only SG server’s device can support Google Home…and I have AC companion that does not show up in SG server. Now it is left useless.

Could you share how you get the AC companion (and many other devices)to show up in SG server? How to re-create the BOOM?


#723

That’s an old post mate and many things have changed since then. Xiaomi seems that fixed the bug that allows us to connect the gateway and other unsupported devices to Singapore server. So, no BOOM anymore!!!
If your main concern is Google Assistant, there are some good news. Both Xiaomi and Yeelight now support Google Assistant in Mainland China Server.
Take a look on this link to check what devices are supported by Xiaomi’s Mi Home Action. There are some Yeelight bulbs included. Of course there is no support for the gateway yet.
A few days ago Yeelight started supporting Google Assistant from Mainland China server, but it’s in beta stage at the moment. If you want to join the beta program then you have to post your Xiaomi ID on this thread


#724

Thanks for your reply. However I like to announce that the old tricks still work and BOOM still happening 3days ago. Mi Home Version 5.4.1.

My devices are all not supported in SG, for example AC companion, Zhirui light, and some Zigbee Aqara sensors. I started with The AC companion, it will only show up in CN server, after following the trick many times by switching the server to and fro, finally the SG server detected the AC device and installed with “fail to connect” error. Even though reported as failure, it shows 1 device connected, but ICON was invisible. I gave up, but on the next day when I turn on MiHome App, BOOM, all unsupported devices appeared on the add screen and I can see my A/C Icon connected.

I was so happy, I can control everything from SG server using MiHome App.
and I thought now I could linked to google Home, However, my dream crushed as devices still cannot be seen on google home app.

So the conclusion is, Even if I manage to make SG server to link to all unsupported CN devices, I still cannot get Google home to work with them, Google home just can’t see the unsupported devices.

Another announcement, yesterday 16Aug, the MiHome APP has a new revision update 5.4.5, After I did the update, the SG server BOOM again, all the unsupported devices disappear from my screen again. By now I am too lazy to retry the trick again to fool MiHome App. I am to tired, simply give up and start to use CN server without using google home voice control.

Just like to share the above experience for those who are in the same path…and it will save you a lot of trouble.


#725

Hi, Any chance to get google home to work with China server on all the unsupported devices? like AC companion and Zhirui light. All these devices are not supported outside China. I am in SG.
Thanks for your help.