Mi gateway on Singapore server


But it doesn’t show up on my google Home
Thanks for your reply


For those that want Home Kit support, I think you might need to buy the new Aqara gateway for it to work.

[Yeelight v2] [Mi Home App] No Option To Add Group

Hi all, I bought 小米智能插座zigbee version but can’t link to my Mi Home App, and the Mi Control Hub keep failed to initialize device. Can I know how? Thanks!


To stormdreamer and psybill, many thanks for your persistence and explanations regarding the Mi Control Hub connected to the Singapore server. I am at my home in the US for only a few weeks a year as I work in Malaysia. To date my home security has been connected to the Mainland China server, but I wanted to switch to Singapore for a variety of reasons. I brought along an extra gateway and finally managed to get it connected to Singapore and get everything (primarily sensors and lights) up and running. I had hoped for more Google Home integration but it’s not a deal breaker.

As I now have two gateways I will now keep the original on the Mainland China along with a handful of sensors and take note of the relative speed and reliability of both.

Thanks again, and keep up the good work.


Perhaps I spoke too soon. After adding or re-adding all devices previously on the Mainland China server to the Singapore server, I now, a day later, cannot see the Mi Control Hub or any of the Aqara devices. I had only set up one automation with an Aqara wireless switch (2 button) and it still works but I can’t see the switch. Perhaps more interesting, I had also added the Water Leak Sensor, but it too has disappeared. Just for amusement, I plugged my first Gateway back in (connected to Mainland China), and tried to add the Water Leak Sensor. However I got a "No Zigbee gateway found, can’t add Zigbee devices. I wonder if others have or are experiencing anything similar.


If for whatever reason you logged out from Mi home or even if tried to change menu language then you lose all the unsupported devices. Don’t worry though, your devices are there and waiting for you. You just need to to do the trick again, login to China server and change region to Singapore as fast as you can. You don’t need to connect the devices again.
As for the second part of your post, I really can’t think what happened to your already connected gateway in Mainland China server.


Thanks psybill. I’ll give it a shot.


Since new update off the app … Gateway and device don’t work… :frowning:

We need to use the old app?


I use 5.3.17 that is probably the latest version and it works just fine for me…


Not for me… sometimes device appeared but without image and I cant use devices… but dissapeard when i close the app


Does anyone have an update on whether we would be able to control Yeelight scene through integration of Mi Home and Google? (aka: Would Yeelight scenes work if the lights are on China server).


Guys I think we have a problem.Let me explain what happened.
As I have already mentioned on other posts, I was able to login to Singapore server not only from my smartphone, but from all my devices, just by doing the trick. All devices initialize and used to work fine.
Yesterday, after a login to Mainland China server and then back to Singapore from my tablet, I could see all my connected devices but none of the normally unsupported devices could initialized and I got a message in Chinese language that the extension failed to start. I tried from my Chromebook and I got the same error. I also tried to install older versions of Mi Home without success.
Now I have only my smartphone that works with the gateway and all sensors. I suppose that if for whatever reason I logout from server I will get the same message.
Does anyone here use more than one device to test it. Maybe the Singapore server party is going to an end!!


We have mentioned many times before as a warning that if you either login to another server or if you change the language at mi home then the gateway stops initializing and you have to do again the procedure… unfortunately this is not something new…

The sad thing is that Xiaomi didnt do what promished to us either through emails or through Yeelight stuff.
The support of the mi gateway on singapore server seems that it was implemented up to a point (with a lot of serious bugs) but then for some reason they just didnt care to finish the implementation and left us waiting for once more. If you dont have a problem with speed at Mainland China and you want to use Alexa for example then you can initialize your gateway back to mainland China and give it a try for the mi home skill (buggy from what i read but kinda works… it will discover your lights through the mihome/gateway). If on the other hand you want to stick with Singapore server then i am afraid that you need to do the same process in the device you have the problem… thats reset the gateway and do the trick with the specific device (the other one should still have the gateway initialized after you finish). Thats the only way it worked for me when i did change the language at mi home and had the same problem with you about 3 months ago and then again when i logged in to mainland china just to check if my camera is discovered there and again had the same problem (thats why i gave so many warnings back then).


Till yesterday I could login and logout from Singapore server from all my devices as many times as I wanted just by doing the trick. All the unsupported devices initialized in a moment a worked flawlessly. No need to re connect the devices.
Since yesterday none of them can be initialized. The gateway, aqara a/c companion and all sensors. Even the Dafang camera that I could connect it to Singapore server but couldn’t initialized, can’t be connected anymore to Singapore server.
Something changed, I am sure for that. It’s not the app version because I tried with older versions.
I will probably go back to China server, I can’t live with that, hoping that Xiaomi’s implementation of Google Assistant will get better


Since this morning everything is back to “normal” on Singapore server. I can login from all my devices, and the gateway and all other devices initializing and working just fine.
I don’t know if it’s related to the issue, but some people on an other forum reported that they could not login to the China Server this morning for 1-2 hours.After their problem solved, I tried with the Singapore and everything was working…


My gateway is not resetting. It says a Chinese voice which I translated with google translate:
“Please remove device from app” but the gateway is not setup or connected to the app, what should i do?


It looks like you had enabled the “Prevent accidental deletion” option in gateway’s settings. Did you?
Are you on Singapore or Mainland China server?


I haven’t enabled that, because the gateway doesn’t even show up on “my home”. I’ve checked every server, I haven’t setup the gateway on any server.


Sorry I can’t help you.
If it is a brand new device and you can’t reset it, then you should ask for a replacement from your retailer. If it is a second hand device, you can ask the owner if he had enabled that option


anyone still connected on Singapore server?
After 5.4 update I couldn’t sing in from other devices using the trick. My smartphone was connected and fully functional though. After 5.4.1 update, the gateway and all other unsupported devices disappeared from my list. I tried to login many times to Singapore server with the trick but I had no luck with all my android devices.
feedback anyone?