Mi gateway on Singapore server


#673

Server back online, i can connect to my camera now…this is fastest blackout ever…last time take days to recover


#674

Correct, works now for me as well :slight_smile:
Thanks!


#675

Hi all !
Thanks for the trick ! I managed to connect the gateway to the singapour server.
However, for some reason, after i tried changing the language, it didn’t work anymore. (Same thing for a wall switch). Also when I want to add new items, the list has shortened and the switch are non longer in the list.
Any thoughts on how to get the gateway and switch back ?
Do I have to do it all over again ?


#676

You don’t need to connect the gateway again. You just need to do the trick to login to mainland China server and change to Singapore as fast as you can


#677

Thanks psybill

For some reasons, the automation works very randomly with the gateway on the singapour server. It worked much better on the china server. For example, when i press the right button on a switch, the log of the app indicates “ClickRight button” but nothing happens, the color of the light doesn’t change as it should…
As for the sensor, I have a lag between the moment when the action it detected and the action (light bulb on)

Is there any solution, maybe on the european server?
(I’m looking for a solution supporting automation while reduce the lag and also supporting google assistant)


#678

Just a guess, but maybe that’s why you can’t officially connect the hub to the Singapore server yet, only with the “trick”? :stuck_out_tongue:


#679

So, I managed to connect the gateway to the european server (in germany) using the same trick being used for the singapour server. After that, I was able to see all the devices (switch, sensors, bulbs etc), like on the chinese server.

However there were some bugs : When I added a light bulb, the last thing of the installation failed (Something with the yeelight plugin). Although it said installation wasn’t complete, it did work, I could turn it on and off; BUT I coudn’t access any of the parameters (so I could’t rename it etc.)
Same thing with the gatway, it seem to work but I couldn’t access anything when clicking on it.

I lost everything on the european server when I tried to logged back onto mainland china and back to the EU

FYI, if you want to test it ou yourself; I use Apower Mirror to control my phone from computer and Ditto to copy paste login super fast.

Any thoughts on any of this ?


#680

I am following this thread and I can’t believe what people are capable of doing to get Google/Alexa voice integration… meanwhile I’m on China server and EVERYTHING (except google voice, which started working like couple weeks ago) is working… Just chill down and wait for Xiaomi to implement all servers, in the meantime use China server… :slight_smile: So now I can even control lights with google assistant (which I have no intention of doing since it is just a gimmick) except V2 bulbs… When I’m home, buttons and switches react instantly and so does the MiHome/Yeelight app since it uses LAN control. Really can’t understand all the fuss about switching to EU/Singapore servers…


#681

The main reason that we want “out” of China server is speed, fail rate, real alexa support (and if you have a logitech harmony hub or other similar devices, then its not gimmick to have a total control with macro commands) etc
Well, just think that if you succeed then you will have minimal problems and everything will be a little better than before (regarding speed etc) but if you fail then no harm done, you can just go back to China and everything will be there waiting (sensors, automations etc).
So i really don’t see the point when people are wondering about other people needs (often judging from their own needs) and they advice them about things that after all nothing wrong will actually happen if they try them and everything cant be reverted :slight_smile:
After all, sometimes, if you know that no harm is done then its actually fun to try things even if they are kinda “pointless” or if you wont gain much (for me this wasn’t the case to be fair)… and you by all people should know better! :wink:

But i agree that changing to Singapore server (and said that before) shouldn’t become a life purpose. I see people try and then getting frustrated that they cant do it, they even get mad or disappointed if they follow other people instructions and wont succeed (since i was the first that gave some primitive instructions, i sometimes had the feeling that a few people were actually mad that my instructions wont always work because they are not doing it quick or they are just unlucky… i know that it was the frustration of the “minute” and not at me personally, but still makes you wonder why guys are taking things that are meant to be fun, so serious).
If we can do it then great, if not, then there is no need to get frustrated and to dedicate weeks on this (i did dedicate quite some time on this just because it is in my nature…).
For me, if you are not having fun experimenting and will get you mad if you fail for any reason, then dont do it.


#682

I get that… but my main 2 points are

  • these devices are used DAILY (lights!!!) and it must be really inconvenient when they’re not working
  • It won’t work 100% until Xiaomi implements this - so IMHO for the time being it is the best and most complete solution to use Chinese server…

regards,
D.


#683

Thanks to this thread, I discover two days ago that it may be possible to connect Gateway and all related devices to singapore server. I try and… Tada !!! it’s working !! I succeed on my first attempt !

I did not see the post of jem24h before trying, so I did not try with European server (I’m in France) and I’m not sure that my wife will accept another downtime in the next few days.

As stormdreamer said, it’s not only to get Alexa or Google Home working : everything is much more responsive !

The only encountered issues are:

  • can’t upload my own sound in the gateway (don’t really use it anyway)
  • I had to close then open again the app to see a newly associated device (aqara button) in automation tab (appears normally in the list). As i add to only add one device, not sure if it is a one time bug or Singapore server related…
  • New automation seems also to take a bit longer time to be active, but after that, no issue (once, even had to close and open again the app to get the automation linked to new aqara button working)
  • also notice that gateway won’t keep the ring color (reset to green after random time), but as I did not use it a lot, not sure that it is related to Singapore server.

I also discover that I can add new radio thanks to ximiraga and Hosts Go (on android, no root needed) to the gateway !!!

To sum up : a great improved for me, thanks to you guys !!!


#684

For me the support of Alexa is the main feature controlling my lights, so the Singapore Server stays my only solution
without third party software.

As I stated before I had the gateway running and managed to use the magic cube remote controller and was able to control the lights with it. I now got my Aqara Motion Sensors and wanted to add them. When I checked in the Mi Home App, the Gateway was not there anymore. I tried to reinstall it, without success. Neither the instructions from Stormdreamer nor the ones from psybill worked. On the China server everything works, including the Aqara sensors. (Gateway Firmware 1.4.1_155.0143, Mi Home 5.3.10, Android 8.0.0).

Is anyone with android able to add the gateway to SP at this moment?


#685

About this, just take the gateway out of power for a few minutes…


#686

It does not work… Still back to green after some times…


#687

I had this problem a few times in the past in both China (most of the times) and Singapore server (one or two times after reset) and from what i remember most of the times unplugging the gateway out of power for a couple of minutes solved the problem. Its a long time since this happened for the last time so i am not sure if i ever needed to do a reset again in any of the times this happened.


#688

I tried what’s suggested here. It didn’t continue as it should as per the instructions but for some reasons when I removed and added the gateway…boom it’s working and initialises on Singapore server. Also I can see all the devices too. I did add a smart power strip and Philips light. None of them initialized properly. However after restarting the app those two have disappeared! Now the gateway doesn’t initialize either.


#689

Hi,
Is there any solution to control the xiaomi smart plugs from google assistant ?
(I’m on china server, but google assistant works now)
Thanks for your help !


#690

Google Assistant is very limited. I have the Smart Fan, Color ligth bulbs, Phillips light bulbs, Rock Robo Vacuume, light strip, Smart power socket adapter +++.

Only Rock Robo Vacuume and color light bulbs are detected in google assistant (using Mainland China server). Echo Dot (Alexa) is not supported at all on the Mainland China server.

Anyone had any luck with the Control Hub on the Singapore server yet? Mine fail to initalize.


#691

Does google home works on the S2 Air Purifier?


#692

According to an user in Taiwan, Air Purifier second version is supported.