Mi gateway on Singapore server


#570

Assistant support coming to Xiaomi’s smart home products, U.S. launch soon

This is promising, don’t you think guys???


#572

From latest news 24 May xiaomi will start selling officially in italy… in some articles I read it seems that some iot devices will be available. In a photo I saw the gateway and aquara sensors… so i hope that my gateway will start working in European server


#573

Hi, I am from Germany and I am still unable to access the gateway via the Singapore server.

Does anyone got the gateway initializing with an iPhone/apple device on Singapore server?

What exactly do you mean if you write in your list of steps: logging in and out of Singapore or Mainland China, just changing the region in mi home setting or changing region to china, sign out, sign in, changing region to Singapore again, signing out, signing in?

My problem is the “Failed to initialize Device” message after installing the the gateway in Mi Home App without timeouts and so on.

Thanks in advance…Don_Z


#574

I have exactly the same problem with Don_zorro using iPhone.


#575

Mi Home 5.1.33 beta (Android). I can see and add all (150) devices on Europe (Recommended) server. No Mi Control Hub, but there is Gateway device.


#576

Hi thanks for the information
There is also an firmware update for the gateway 1.4.1.155.0143.
i’am updating and crossing the finger


#577

Logging in to Europe server from other devices, I can see only 9 devices available to add.
My smartphone is on 5.1.30 and connected to Singapore server with the tricky way, so I don’t want to risk it at the moment…


#578

Weird… I did this update on MiHome but it doesnt show Europe (recomended), just Europe, and has only 9 devices.


#579

With 5.1.33 I can add all my devices, gateway, sensors, switch, doors contacts, bulb, xiaomi robot, but couldn’t upload any devices.


#580

#kubikub
what do you mean could not upload? Could not initialise or something else?

I see Europe (recomended) but with only 9 devices.


#581

I’ve just tested version 5.1.33, the didn’t fix the problems.
Gateway doesn’t work on Singapore server, only on China server.
I don’t understand why they even added the Gateway to the list when it’s not working.


#582

Couldn’t initialize message. I can not enter into any devices.


#583

And did you succesfully add the devices and Gateway to the EU server? Is automation working correctly?


#584

Nope… I have 37 devices connected, and a lot of automations. Don’t want to start from scratch. :grin: I only add 5 Mi Floras but still, everything was in chinese. I really don’t understand this company, dedicated app (Flower Care) looks exactly identical like in Mi Home and everything is translated not only to English but also to my native language (Polish).


#585

after several logins/logouts to EU, Singapore server from my chromebook, I can now see more than 9 devices available in Europe Server. Not 150 @Lolek1 said on his post but is a good start.

Update:
After clearing the data and cache on my device, the available devices in Europe server are back to 9.
What I noticed is that screenshot above,taken from Europe server, matches with the list of official supported devices from Singapore server. Into my eyes, seems like the same bug that allows some of us to connect the gateway and other unsupported devices to Singapore server. I am really curious to see what will happen on May 25th with the beginning of the GDPR :hushed:
Update 2
Guys I think that I am now able to reproduce the scenario of making all the devices of Mainland China server visible to Singapore or Europe server. It’s nothing new though. It is exactly the same trick we do when we want to add the gateway to Singapore.
You just need to “confuse” the app with changing servers quickly. You can try to clear cache and data of Mi Home app and start from scratch. Login to Mainland China server and don’t let the app load your home information or load the available devices. Just go to the profile tab and change your region to Europe or Singapore. If you are really quick then you will see the mainland china devices to be available to add in Europe or Singapore server. If the first try is unsuccessful try once again. For me is working almost every time. On my original post with the screenshot I was changing from Singapore to Europe, that’s why I was able to see 33 devices.
That may help some people here that they are still trying to connect the gateway to Singapore server.
Of course that doesn’t mean that that the devices we can see in Europe Server are working like the Singapore server. I don’t want to break my setup in Singapore at the moment so I didn’t try to connect the gateway.
What I’ve tried, is to connect the dafang camera. In case you remember I can connect the camera to Singapore server but it doesn’t work. In Europe server I get a connection time out and camera does not connect to the server. I also tried a Philips E27 bulb that I can successfully connect it, switch it on and off form the toggle , but I can not enter into the bulb menu and settings


#587

Thanks, now I am able to see my gateway on singapore server and add to devices, only problem is that gateway is now Offline, because I reseted it before. But I keep trying.

Now gateway is online on SIngapore server. Will report back soon.


#588

@jimrapc I don’t know where you are living, but why don’t you try the Europe server to see if it works…


#589

Thanks, it is working on singapore server now :smile: I am happy now.

DO EVERYHING LIKE @psybill described and you will get it working on singapore server!!!


#590

perfect, now I’m on the Singapore server, I see all the devices in the list (mi home control and gateway) I have to reset at this point my gateway to add it?


#591

I am afraid yes. You are going to lose everything you had set up in China server