Mi gateway on Singapore server


#550

In germany, i did not see the Mi Home skill yet, only the Yeelight


#551

I’m from Portugal.
A new version of Alexa app was released on android. I installed the update right before installing the skill.
See if it works for you @progro


#552

I’m on version 1.24.201568.0 of the Alexa app.


#553

No, not yet. I am on 1.24.201568.0 too, but no MH


#554

Just an update on this: Mi gateway on Singapore server
As i said on that post, not only changing server but also changing language can make the gateway disappear from your devices inside Mi Home (although strangely enough sub devices and automation already added keep working) and since i did the mistake to change the language about a week ago (and lost the gateway in Singapore…) i had to find some free time to try again.
So today i found some time and although i was a bit worried that if i failed i would loose even working automation, it took me only 5-6 minutes to add the gateway again, more or less following the steps i described a couple weeks ago BUT this time it was even easier because i tried another trick and strangely it worked.
The steps i followed are:

  1. Being logged in Singapore server, i did a reset to the gateway. Even though i heard the Chinese prompt, the yellow light wasn’t blinking as it supposed to, so i took the gateway out of power for a few seconds, then back to ac power and then reset AGAIN.
  2. Now that the light was blinking, i logged in to Mainland China and then right away to Singapore server again and the Gateway was found.
  3. I begun the installation knowing that it will fail with a timeout (it always does the first time as i said before).
  4. After the failure i did a reset again and did the same process all over (reset, china and then Singapore etc… dont remember if i did it one or two times more) thinking that it might connect right away like it did the last time. It didnt (time out again at 90%) although i knew that if i did that a couple of times again then at some point it would be a success.
  5. Here is the new trick… when i got a timeout again i turned the gateway light on from the physical button (when the gateway times out, it actually connects to the wifi and stops blinking yellow so you can turn it on physically), i checked my device list in mi home (NOT the default favorites list but the one with whole devices of mine using the “house” image on the left of the screen). There i saw the gateway as “new” and OFFLINE (as always at this step) but when i pressed on it i heard a new Chinese prompt and started initializing (0 to 100 and then ready) and it was installed without problems.

This was an easier way for me found by luck and i am sharing in order it helps anyone.


#555

Cool @stormdreamer!

Until now, testing the alexa skill i see a 90% success rate. Sometimes i get a message saying that the device is inaccessible, but it is like 1 time in 10 voice commands.
Looking directly into the app, on the skill settings, i can see an intermittent “connection lost” warning most of the time.

If anybody can test this and post their experience would be nice.


#556

Thank you @stormdreamer! for your ongoing testing and your patient descrybing to make us have the gateway in singapore too.


#557

no way. I followed exactly your steps

  1. singapore
  2. reset
  3. the light does not flash
  4. I unplug the gateway
  5. I reinsert it and the light starts flashing
  6. I reset the gateway again
  7. I enter the mainland china server
  8. I detect the gateway
  9. I return on the singapore server and add, timeout!
  10. I turn on the light and nothing happens. I cant see any devices on the list

Tested for 1h continually to follow the same procedures, nothing to do! For me it does not want to work and I can not really understand why some people work and others do not.


#558

As i said you may need to do it more times… reset again, again china and back to Singapore (unless after the reset you see it right away in device list) and try to add again (or see it you find it in device list as offline).
Always check in every cycle if its in the device list as offline, if you find it there then this is the time that it will succeed.
Be patient, if it doesnt work dont get frustrated, leave it for some time and try again in an hour or two.
There is no other way right now unfortunately…


#559

I’m also getting the “timeout” error, the weird thing is the Gateway isn’t shown on the device list, but the device count is 1, and I can make the button\temperatures sensor work but no gateway.


#560

@Stormdreamer, thank you for all your efforts to help us.
Unfortunately, I always getting timeout error. No matter how many times I repeat the exact steps and procedure described. Gateway devices also not showing in device list, even though I have tried turning on the built in light after timing out.

@Obg1234 My device count also showing 1, but gateway/control hub is not listed in device list.


#561

Hey guys, one question.
How can I configure the door sensor to play alarm ONLY when the gateway alarm is on?
I dont know if it is because the Singapore server and its not working now (I dont wanna to move again to China server to test it and loose all my configuration again).

So, I just wanna to put the door senor to play alarmr when open the door only when alarm gateway is on.


#562

You mean to use the door sensor as trigger for the alarm? (dont understand the “play alarm” from the door sensor…)
If yes then inside the mi hub (gateway) you go to “Auto” -> “Alert” -> “Alert Trigger Device” and choose the door sensor and whatever other sensor you want.


#563

Yeah, this is what I am looking for, thanx!
When I was using China Server, I configurated everything using the old app, and I dont remember some things, like this.

And sorry my bad english!


#564

Hi guys!

I have bad and good news.

The bad news is that the mi home skill for Alexa is not a good solution. Yesterday failed a lot, always saying that the device (yeelight color bulbs) was unresponsive. I presume that it’s due to China server being so slow.

The good news is that finally I got the gateway working on Singapore server :slight_smile:

I followed @stormdreamer steps again and in the first attempt the gateway was not detected.
I logged in into China server again and left the gateway in reset mode and unplugged from the wall for about 2h.
Then I plugged the gateway into the wall (it was already in reset mode), logged directly into Singapore server and, without doing anything, this time i could see the gateway and switches in offline mode (strange but it is true).
Then I clicked on the gateway on mi home app and it started to establish connection but gave me a timeout on first attempt. Second attempt to connect I pressed the button on the gateway (one single click) and it finished the configuration!

Everything is working just perfect now, Alexa never fails when dealing with the lights and all my devices are working perfectly and the connection was made on first attempt.

Very special thanks to @stormdreamer for sharing his experience with us which is leading us to successfully connect or mi devices to Singapore’s server.

Guys, keep trying, it ends up as being as question of persistence!


#565

Hi,
I tried more than 10 times. After Chinese i loged in to Singapure server and it is processing to 90% , and than he told me “TIME OUT” . It can not go to finish (100%). I tried so many times to “reset”, start again, and every advice which i read in forum, it is still not working


#566

unplug it from power for a few seconds (or minutes) and plug it again and logout/login to Singapore (China -> Singapore) and IF you see the Gateway as offline at some point in your devices then this is the time that it will work and initialize (at this point you will also see the device list that you can add that it will be a lot bigger and you will find “Mi Control Hub” in the list). Unfortunately there is no standard procedure and what worked for me and few others isnt working for all. We need to gather every step followed from now one from people that succeed in order to understand what is the exact step that does the trick (unless it is after all pure luck or timing in the server… but two times for me and very quickly that would be a lot of luck so i dont believe so… i am not a lucky guy :P)


#567

Aqara is bringing Alexa and HomeKit support soon. (Aqara makes the sensors and gateways for Xiaomi). They said they’ll release it around July this year.


#568

Same for, was not able to connect to Singapore server => timeout, tried several times!


#569

I’m having the same time problem, I think the best thing to do is hope for a software update to fix it.