Mi gateway on Singapore server


#510

My list is a lot smaller than yours? How is that?


#511

it’s 2:30 after midnight here in Greece and finally I did it. The gateway is now properly connected to Singapore server as Mi Control Hub.:stuck_out_tongue:
The key point, as @stormdreamer said is the yellow light. You have to see it blinking for a long time, and the logins and logouts from Singapore to China and finally to Singapore.
Needless to say that after the gateway connection my list of available devices is the big one as it shown on @stormdreamer screenshots some days ago. Everything seems to work fine on first look, but I will need to double check all devices and automation tomorrow.

For the record: device Nexus 6p, Mi Home v.5.1.30


#512

Now that there are some successful changes to Singapore server, do you feel automation is any faster? Or you managed to control with voice?


#513

Hi Psybill, Did your Aqara AC Companion Gateway worked on Singapore Server?


#514

As I said on previous post, both the gateway and aqara a/c companion were connected to Singapore server even if I was getting the timeout error. There weren’t available to my devices list though, so I couldn’t use them.
After the successful connection of the gateway, the aqara a/c companion appeared instantly on my list and I was able to initialize it just fine. I haven’t set any automation with the device yet but I suppose that is working fine.
Guys just remember that you can see and use the “normally” unsupported devices only from the device you have successfully connected the gateway. I have an android tablet and a chromebook that I have sideload Mi home app and all unsupported devices are not in my list.
In my case those devices are:
Gateway
Aqara a/c companion
Aqara light control smart switch
Aqara temperature and humidity sensor
Aqara door sensor
Philips connected bulb
And xiaomi dafang camera
The dafang camera (not xiaofang I said by mistake to @stormdreamer) is a new entry in my smart home devices. I set it up to China server and it worked fine. On Singapore server I can successfully connect the device but I can’t initialize it. I will do some test later today


#515

Lucky boy !!!
I spent the morning trying to pair with singapor again.
Each time the same result => timeout during pairing process.
I’m so close to success it is frustrating


#516

I’m in the same situation you are.
I’m trying to configure the gateway in the singapore server since two weeks ago, trying diferents methods but without success. I’m from Portugal. Yes it’s very frustrating. And each time i try the automation stop working for a long time.


#517

From the UK - having the same problems as most others.Trying to pair the gateway (v2) and switching from china to singapore on android I get the timeout during the pairing process.

However, the same as other commenters (Mi gateway on Singapore server) the gateway will pair with my ipad on singapore server (do not even have to do the china switch), but the device will not initialize. But, (also as other commenters have said) it will then allow me to add my mi wireless switches and they work flawlessly. I can set up automation to control the yeelights etc. The switches can also be used to control all the functions of the gateway itself (lights on/off, radio on/off) so it clearly is working even if it will not initialize.


#518

Someone’s on r/xiaomi posted a picture of the new Gateway and it has that rounded look from the HK websites and it came with a US plug, interesting.


#519

A link to the topic would be useful. I can’t find it on reddit.
Is this a US plug?


#520

Sorry I forgot to post the link, here: https://www.reddit.com/r/Xiaomi/comments/8fkigs/new_xiaomi_gateway_anyone_else_have_or_seen_one/?st=JGKTRNYW&sh=3e151aba


#521

Hong Kong uses a different plug type from Mainland China. Xiaomi probably just made a different version of the gateway just for Hong Kong.

Hopefully, now that Xiaomi have a made a gateway with a US plug type, that it’s easier for Xiaomi to launch the gateway and sensors in the US market, or I could be wrong completely. I don’t know, that’s just my theory.


#522

If you visit the reddit topic again you will see that the guy is from Taiwan and he purchased the hub from a local store. He explained that Taiwan use the same plugs as US, something I didn’t know to be honest


#523

It the hardware is the same, would it be possible to flash the new gateway’s software on Gateway V2? Than maybe it would be fully functional on Singapore server from Android as well.


#524

Also, there is a new Alexa skill (Mi Home) which can controll bulbs and plugs on any Xiaomi server.


#525

I did a new reset and now it doesnt worl anymore on Singapore Server like was before.
I did everything like stormdreamer tips and doesnt work anymore. :frowning:


#526

Risky move. I wouldn’t dare to reset gateway or clear app data on my smartphone. May I ask why did you reset your gateway?


#527

Actualy first I changed to China Server and tried to unlink Mi Remote. When I tried to connect on Singapore again, the gadgets are gone, so I tried to do everything again.


#528

Can you give me a link to the new one? I can only find the old Asia & the US Skill


#529

I see… Sometimes happens to me when changing servers, especially when returning to China server. I can see none of my devices, I also can’t see any devices in add new device menu. It needs a few minutes and everything comes back. Good luck…