Mi gateway on Singapore server


#489

Its not as simple as that (wish it was…) with the SAME account and same model of phone in my phone i see all devices in the list but in my wife’s phone i see 1/3. Unfortunately there is no logic. Maybe its because i did a clear cache in mi home app a few days ago? you guys can try this also but i am afraid that its just… luck.


#490

Dosen’t work anymore… really weird… it works everytime with an iphone or not ?


#491

Hi thanks for the tips, but not luck for me too from france.
Same mi home app version and gateway firmware try your procedure many time but with no luck.
I saw the gateway icon in the add manually procedure, i saw the gateway wifi SSID lumi-gateway-v3_miap1dab but mi home do not see it.
Android8.0 on galaxy S8+ tried to remove cached data too…


#492

I tried a few things.

  1. tried with an Android phone - still the same incomplete device list
  2. tried with an iPad - incomplete list
  3. tried with the same iPhone (that was successful earlier on) with another Mi Account - incomplete list

I think if you dont see a complete device list, be patient. It will eventually come.


#493

Finally, it worked for me. I did it as Stormdreamer described.
I could add the gateway and now my Cube Controller works.
Android 8.0.0, Mi Home 5.1.29 and Gateway 1.4.1_154

What I miss is the possibility to access my yeelight scenes in the mi home app.
Now I have to recreate all my scenes for the cube controller.


#494

What version of the App you are using? What language is set in the settings? I’m only seeing partial list with devices that are in English only


#495

Mi Home 5.1.30 is out now on playstore and apkmirror, for those who did not make it with 5.1.29. I still can’t test it myself because of the internet connection breakdown


#496

.30 do not solve the issue for me.
There is definitevly something around the account or the gps location. I’ve tried so many thing android/ ios different account, spoofing the gps position … nothing help


#498

Homekit and Alexa support for Xiaomi/Aqara gateways and sensors is coming soon!

Homekit support will be relased in the second half of this year and Alexa support will be added by the end of this year. No news on Google Home support, but expect it to come out sometime next year, maybe spring?

https://www.youtube.com/watch?v=hT2o3lW_QmA


#499

Man, I just want to say thanx for you! I did exactly what you said and now I have everything working!
Lamps, swtiches, erverything!
Thanx!


#500

Glad it worked for some of you guys :slight_smile: Lets hope that everyone will manage to do it eventually.
If we could only find out whats the difference between those who succeeded and those who failed to connect following the same (?) steps.


#501

@stormdreamer have you update the app to 5.1.30? is it still working for you?


#502

I just updated and i still have everything setup and working properly in Singapore and see the big list in devices.


#503

i’ve tried with android 5.1.30 and Gateway 1.4.1_154.0143 with the steps above - china, scan, see hub#, switch to SG, connect the hub.

problem is, after connecting “successfully” the hub, i’m not able to see the hub in the app. but subdevices like door sensors, motion sensors etc added themselves to my app list (without having to reset the subdevices). the sensors work as in able to see when motion is detected, when door is open/close etc but couldn’t setup automation.

couldn’t setup automation from the subdevices, nor from the hub - because the hub is still not visible in the list.

tried few more times to reset the hub, but same issue. in the end i put everything back to china server for the moment till the next “update”


#504

I know you probably already know that but the default view is the “favorites” view…
Have you checked the “home” button in the left? if you connected the hub succesfully (without timeout) then it should work and it should be there.
Have also in mind that if you used a specific device to do the setup, doesnt mean that you will see it in a second device when you login with the same user.
I also can add some automations only through the hub (i had the same problem in China)


#505

It works, thanks😆


#506

Mission: Unsuccessful
My internet connection is finally working again, so yesterday I tried to connect the gateway to Singapore Server.
I tried with different versions of Mi Home (.25, .29, .30), different devices and two different mi accounts. I removed the device from China Server and while it was on reset mode I changed to Singapore and I can see the gateway available to add it. On 60% I can hear the well known girl saying something and on 90% I get a connection timeout. I have also an Aqara A/C Companion that is also a gateway and I get exactly the same results.
I can not see the two devices on my device list but I am sure that they are connected to the server. If you notice my screenshot you will see that there are 8 devices available, most of them are mijia sensors and wireless buttons and on my profile I can see 10 devices connected to Singapore Server. Mijia sensors connected automatically to the gateway. None of my Aqara branded sensors and devices are connected.
I will try to find an iphone today from a friend to sign in to my Mi account to see if I can do something. Of course I can see the short list in available devices.
Like @stormdreamer, I am from Greece, so I suppose it has nothing to do with location.


#507

The steps that you described are not the same steps i followed so can you read them carefully again and do another try?.. i have said that the first try might be unsuccessful and that what i did is reset the gateway again (while in Singapore), login to China and then login back to Singapore and it worked (had to take it out of ac power and put it back on at a point where the yellow light stopped flashing).
Its like when it times out the first time, keeps the gateway in “memory” but not actually connected and the second time (when you logout of singapore and login again) its a success. You will know that you are close especially if you see the gateway in your device list as offline after the logout from Singapore, login to china and then back to Singapore (thats the gateway from the previously unsuccessful try).
Please check my posts, do the exact same steps like me and tell me the result :slight_smile:

  1. Mi gateway on Singapore server
  2. Mi gateway on Singapore server

PS. Have in mind that if you have a Xiaofang camera (the square one with the magnetical base) it wont function in Singapore (setup times out at 90%)… at least mine doesnt.


#508

I am sure that I plug the gateway out of power many times, I am not sure if I did it as you describe on the second post though. I will try again today.

ps. 10 minutes ago I received a Xiaofang camera and I will let you know if it works on Singapore Server. Have in mind that I can see the short list of devices and Xiaofang is not there for me.
I also had some problems to connect the 720p 360 camera but I noticed that I did something wrong with the QR Code Scanning…


#509

From India and I have the exact same outcome even after retrying the steps multiple times.