Mi gateway on Singapore server


#428

I could connect the gateway (v2) as well with an IOS device on the SG server. If I click on it, it says “Couldn’t initialize device”.
The only “sensor” I have is a Mi Cube. I could connect is as well, but again, if I click on it, it says “Couldn’t initialize device”. I have several yeelight lamps, but I guess, that without intializing/configuring the cube I can not use it. Any movement of the cube does not do anything.
Does someone has experience with the cube?

BTW I can not see the gateway nor the cube on my android device.


#429

things don’t look good even with iOS setup at the moment, so it’s better to wait.
can anybody with an iOS device provide a screenshot with the available devices in Singapore Server?
I just want to check if android and iOS have the same devices. here is mine from an android device


#430

Actually. It is working fine enough for me. The motion sensors. The WiFi switches, and the door sensors are working as intended on the Singapore server. ;). All mihome branded sensors.


#431

I’m still following this thread, even if I was tired to wait for Xiaomi Gateway integration (I already tried twice with Android device on Singapore server without success), so, I moved everything to Mainland China. Both Yeelight devices and Xiaomi Gateway/Sensors. Then, I installed Home Assistant on a Raspberry Pi, and I have everything integrated and working perfect. I can command the lights via Google Home (voice commands), and via Gateway/Sensors. Plus, HA automation is “another world” compared with Mi Home where they are almost all in chinese language. But, also the conditions we can configure in HA is almost infinite and much more flexibles.
Raspberry Pi can be purchased at very low price, and also power consumption is very low. I strongly advise everyone to take a look at this solution.


#432

Can you show how to do it? Is there any site with instructions?


#433

Internet is full of tutorial about it, I installaed Raspbian OS and then Home Assistant, because I can use the Raspberry also for other things, but you can install Hass.io. It’s an OS dedicated only to HA.
Here a good point to start:
https://www.home-assistant.io/getting-started/


#435

Lucas you said that again 8 days ago and a pointless offtopic discussion started for days that took people start complaining to make it stop.
Is there a reason to say the same OFFTOPIC thing and start the same OFFTOPIC discussion all over again just a week after the previous one?
You havent discovered the wheel, we have discussed about hassio, openhub etc many months ago on this thread back when there was no hope for a solution for Xiaomi (i too use hassio many many months now in a pi2 together with IFTTT as many people in here do), but now that we are so close to a solution, repeating the same offtopic discussions and ruining this thread is not helping noone and for sure doesnt help people that are watching this thread for its actual purpose and run whenever there is a new post only to discover that its about the same offtopic theme again.
Whoever wants to find out about third party solutions then he can take a look at past messages (it has been discussed many times before) and also google is his friend.


#436

I believe that here we are discussing on how use the Gateway in other server than Mainland China and/or integrate Yeelight devices+gw+voice assistant and so on. Am I wrong?. I don’t believe I was offtopic. I only reported my experience after one week of configuration and usage, and after waited Xiaomi for months.
The fact is that there is a lot of confusion here in this thread, some people are able to add the GW to Singapore Server, but a lot of things doesn’t work, need to use iOS (?), etc.
And yes, I discovered the wheel, because Raspberry HA solution is much better compared to Mi Home app. So, why insist to search a Singapore server compatibility when is clear that Xiaomi doesn’t care for non-Chinese customers? Is time to look forward and I simply shared my experience with another (much better) method to do what the topic ask.


#437

Actually that is your interpretation so yes i believe you are wrong and offtopic because the title of this thread is pretty specific. Hassio has its own forum where yeelight and Xiaomi integration is being discussed and if we need to do in this forum then you could open a new thread and i will contribute as much as i can.

But beside all that you are missing the point. The main problem is not the fact that you talked about hassio. Is the repetition .
I tell you again that we have talked about hassio again and again in the past and it was only 8 days ago that you were saying the exact same things! There is no point of such repetition and the only thing this does is creating a mess.
All the methods you are talking about have been discussed before and you may not know it but most of us already use these methods.Just Imagine if all of us who are using hassio or openhub or whatever started posting about this in here. We dont because thats not the purpose of this thread.
I and others have been very patient and it took 10 days to tell you this just because i didnt want to start an argument with you but as you say there is already a lot of confusion on this thread so why you want to add more?
Imagine a new user that comes for the first time and see the thread “Mi gateway on Singapore” only to find out that 300 out of 430 posts are offtopic
Anyway do whatever you guys want, i wont tell you what to do or not but for me its a pity to ruin this thread with so many offtopic messages. If you dont agree then no worries.


#438

I noticed that with the latest update of the gateway (a few days ago) it was renamed to “Mi Control Hub” within the device settings like we saw in the device list of Singapore server (maybe someone else has mentioned this before, i am sorry repeating this if this is the case, since i got the firmware update late compared to others… my tests were done with the previous firmware).
This is a good sign since we are indeed talking for the same device. I dont know what else was changed with this firmware update (1.4.1_154.0143) since as people said before it is still not working for Android devices on Singapore server.


#439

@stormdreamer I am an android user too, but I can’t see any changes in the gateway’s name after the update. where in the app did you notice the new name? Are you going to make another try with the new firmware?
By the way, I also sent an email to xiaomi global support asking about the gateway and other devices on Singapore Server. The gave me the same useless answer that they don’t sell those products globally, so they don’t provide support and warrant. They also promt me to contact xiaomi Singapore support (service.sg@xiaomi.com). They replied really quick, but short answer is that they have nothing to share at the moment.


#440

Is there any difference between my Singapore server hub control with the Chinese server gateway?
today the devices on the singapure server have increased and there are two gateways


#441

When you go to the gateway and then to “device” tab (after the “gateway” and “auto” tabs on top of the screen), you see there the gateway as “Mi Control Hub” … i remember the name was different.


#442

Android or IOS? On Android, I dont see a second device in Singapore server, only the “Mi Control Hub” device in the list.


#443

Still gateway for me. You can rename it to whatever you want though. Is there any chance the device took that name when you add it back to China server after the fail with the Singapore server?


#444

If I go go Singapore server ( I see mi control hub on device)

It will work ?


#445

Hi, Jeff.
May I know how to make MI app to recognise S20 WiFi plug?
Btw, are you using SONOFF?


#446

I have configured the gateway in ios,
yesterday I left two gateway, today the app has been updated and I only get one.


#447

I have a gateway in singapore and another in china, because all the devices do not come out in singapure, in the two servers it works all right


#448

well SUCCESS :slight_smile:
I now have everything (gateway and all sensors and yeelight lamps… 20 in total sensors and lamps) under Singapore server.
I did it using an android phone.
Mi home is version 5.1.29 and gateway has firmware version 1.4.1_154

I found some time to try again after my last unsuccessful attempt last week (but this time with updated mi home and gateway).
The first try was again unsuccessful, i did a reset to the gateway and then logged in to the Singapore server but the gateway was not found, then i left the gateway in reset mode and i logged in back to Mainland China and directly back to Singapore server and the gateway was found. I added it without problems this time and it initialized without any problems!! (EVERYTHING is working in settings). I had the issue that the light turned green after a few sensors but this was solved by taking the gateway a few seconds out of the ac power.
I didn’t even need to add the sensors again. Every time that i used a sensor (either pressed a button or pass in front of a body sensor or open a door with a sensor), it was found automatically just because it was already added to the gateway to China. The Humidity sensors just needed a few minutes (enough to send a reading) and they were found also.
The only sensor that wasn’t found automatically although i pressed it was one of two aqara switches (Oh yes i forgot… aqara switches work perfectly and recognized as AQARA). So i had to add it manually and it was added without problems since aqara switches ARE now included to the child devices of the gateway!!

After that i did a reset to the yeelight bulbs and added them to Singapore (using mi home…) and then created all automations for the switches (single. double, long press) and everything is working PERFECTLY.

Tomorrow i will fix the rest of automations but everything seems to be working perfectly!