Mi gateway on Singapore server


#539

Yeah what are you doing differently. I followed the exact same steps and still get the connection timeout.
Did you change anything in the language etc.?


#540

@stormdreamer if you are looking for ip cameras that work on Singapore server right now then you can try the mijia 1080 and the Mijia smart 720p PTZ. Both work great for me…
Another “unsupported” device that works for me in Singapore server is the Philips Connected Bulb, but I will remove it form my ecosystem and replace it with a yeelight because of the Google Assistant integration.


#541

Exactly nothing! First try in the morning and it begin to work!


#542

Language : Default. I disconnected from power 5-6h and then first try in morning worked.


#543

Mi Remote doesnt work too.

I changed the server and, after several tries, could connect all devices on Singapore (but a did a clean setup again).


#544

Another semi-working device on Singapore Server for those with a connected gateway. Guess what? It’s the Yeelight V2 bulb. Normally the V2 bulb is not listed in the Singapore server, but its in the list for us with a successfully connected gateway.
Today I received my first V2 White bulb and I tried to connect it to Singapore server through Mi Home app to see what will happen. Bulb connected succesfully, but I can not access bulb’s menu. Fortunately, I can create an automation with the bulb. I have set it up with a motion sensor for on/off and it works fine. Of course the bulb added in Yeelight app automatically and I can control it through the app and with Google Assistant.
@weiwei any official response on this? When are you going to support v2 bulb on Mi Home app? As I can see on the other thread there some problems on China server too


#545

Hi guys,

I’ve been following this thread for a long time, waiting for the bulbs to work with Alexa without additional automation like home assistant.
Finally I see people getting the gateway working on Singapore server and that’s amazing. I’ve tried to replicate stormdreamer (awesome man) steps on my setup but I was always get a timeout.

While reading this thread, I noticed malnabokor post (thanks a lot man) saying that there is the new “mi home” skill for Alexa that supports China server for yeelight bulbs and bam! It really works. Finally I can control the lights with Alexa :slight_smile:

The point is, now that we have a skill that controls the lights in China server, what’s the point of moving into Singapore server?

Keep the good work everybody! You guys rock!


#546

Glad you found a solution that is working for you!
Yes i also noticed this skill i enabled it two days ago and noticed that alexa finds the devices twice now (dont know if this happened before) so probably yes it is working.
“what’s the point of moving into Singapore server?”
Well there is a misunderstanding that we want another server (like Singapore) just for Alexa or IFTTT… no this is not the main reason (at least for me) the main reason is that especially for European users, China server is really really slow and buggy.
I saw a post from Weiwei in another thread pointing that probably soon Xiaomi is going to have every device in European server (Germany) and this would be the best solution (also he was saying that from that point the China server wont work for us anymore, dont know if i remember this well).
So if we can get rid of the slow and buggy China server then it would be great… but if not then yes, the Mi Home skill (as long as it works properly all the time) is a temporary solution for people waiting for either the European server or at least official support of Singapore server.
Maybe at this point and if you guys on China server that have enabled this skill, confirm that everything is working OK all the time, then i would also suggest to stay in China server and enable this skill since Singapore server is far from ready and stable (for Gateway).
Can you do a “stress test” on this skill so people (that only care about alexa) can know if they should stop trying with Singapore server and use this instead?

PS. Found the post from Weiwei Multiple Server? i dont know if with “products that are targeting EU market” includes Gateway and all sensors and i also dont know what “I don’t think you could use Chinese server anymore” means but it doesnt sound good to me…


#547

I will test the “mi home” skill stability during this weekend and then I will post the results.
I installed the skill yesterday late night and only tested it a few times, like 3 on/off cycles, and actually it fail once.
I also have a xiaomi mijia 1080p cam. I think that, for this reason and based on ppl comments, I will have to remain kind of stuck on China server.

Thanks for your feedback stormdreamer.


#548

@W4RPZZ, Mijia 1080p works great on Singapore server


#549

@psybill thanks!!!

Considering this, and the fact that Singapore server is faster, I think that i will give it another try on registering the gateway on Singapore server next week so I can test the skill stability during the weekend.


#550

In germany, i did not see the Mi Home skill yet, only the Yeelight


#551

I’m from Portugal.
A new version of Alexa app was released on android. I installed the update right before installing the skill.
See if it works for you @progro


#552

I’m on version 1.24.201568.0 of the Alexa app.


#553

No, not yet. I am on 1.24.201568.0 too, but no MH


#554

Just an update on this: Mi gateway on Singapore server
As i said on that post, not only changing server but also changing language can make the gateway disappear from your devices inside Mi Home (although strangely enough sub devices and automation already added keep working) and since i did the mistake to change the language about a week ago (and lost the gateway in Singapore…) i had to find some free time to try again.
So today i found some time and although i was a bit worried that if i failed i would loose even working automation, it took me only 5-6 minutes to add the gateway again, more or less following the steps i described a couple weeks ago BUT this time it was even easier because i tried another trick and strangely it worked.
The steps i followed are:

  1. Being logged in Singapore server, i did a reset to the gateway. Even though i heard the Chinese prompt, the yellow light wasn’t blinking as it supposed to, so i took the gateway out of power for a few seconds, then back to ac power and then reset AGAIN.
  2. Now that the light was blinking, i logged in to Mainland China and then right away to Singapore server again and the Gateway was found.
  3. I begun the installation knowing that it will fail with a timeout (it always does the first time as i said before).
  4. After the failure i did a reset again and did the same process all over (reset, china and then Singapore etc… dont remember if i did it one or two times more) thinking that it might connect right away like it did the last time. It didnt (time out again at 90%) although i knew that if i did that a couple of times again then at some point it would be a success.
  5. Here is the new trick… when i got a timeout again i turned the gateway light on from the physical button (when the gateway times out, it actually connects to the wifi and stops blinking yellow so you can turn it on physically), i checked my device list in mi home (NOT the default favorites list but the one with whole devices of mine using the “house” image on the left of the screen). There i saw the gateway as “new” and OFFLINE (as always at this step) but when i pressed on it i heard a new Chinese prompt and started initializing (0 to 100 and then ready) and it was installed without problems.

This was an easier way for me found by luck and i am sharing in order it helps anyone.


#555

Cool @stormdreamer!

Until now, testing the alexa skill i see a 90% success rate. Sometimes i get a message saying that the device is inaccessible, but it is like 1 time in 10 voice commands.
Looking directly into the app, on the skill settings, i can see an intermittent “connection lost” warning most of the time.

If anybody can test this and post their experience would be nice.


#556

Thank you @stormdreamer! for your ongoing testing and your patient descrybing to make us have the gateway in singapore too.


#557

no way. I followed exactly your steps

  1. singapore
  2. reset
  3. the light does not flash
  4. I unplug the gateway
  5. I reinsert it and the light starts flashing
  6. I reset the gateway again
  7. I enter the mainland china server
  8. I detect the gateway
  9. I return on the singapore server and add, timeout!
  10. I turn on the light and nothing happens. I cant see any devices on the list

Tested for 1h continually to follow the same procedures, nothing to do! For me it does not want to work and I can not really understand why some people work and others do not.


#558

As i said you may need to do it more times… reset again, again china and back to Singapore (unless after the reset you see it right away in device list) and try to add again (or see it you find it in device list as offline).
Always check in every cycle if its in the device list as offline, if you find it there then this is the time that it will succeed.
Be patient, if it doesnt work dont get frustrated, leave it for some time and try again in an hour or two.
There is no other way right now unfortunately…