Mi gateway on Singapore server


#443

Still gateway for me. You can rename it to whatever you want though. Is there any chance the device took that name when you add it back to China server after the fail with the Singapore server?


#444

If I go go Singapore server ( I see mi control hub on device)

It will work ?


#445

Hi, Jeff.
May I know how to make MI app to recognise S20 WiFi plug?
Btw, are you using SONOFF?


#446

I have configured the gateway in ios,
yesterday I left two gateway, today the app has been updated and I only get one.


#447

I have a gateway in singapore and another in china, because all the devices do not come out in singapure, in the two servers it works all right


#448

well SUCCESS :slight_smile:
I now have everything (gateway and all sensors and yeelight lamps… 20 in total sensors and lamps) under Singapore server.
I did it using an android phone.
Mi home is version 5.1.29 and gateway has firmware version 1.4.1_154

I found some time to try again after my last unsuccessful attempt last week (but this time with updated mi home and gateway).
The first try was again unsuccessful, i did a reset to the gateway and then logged in to the Singapore server but the gateway was not found, then i left the gateway in reset mode and i logged in back to Mainland China and directly back to Singapore server and the gateway was found. I added it without problems this time and it initialized without any problems!! (EVERYTHING is working in settings). I had the issue that the light turned green after a few sensors but this was solved by taking the gateway a few seconds out of the ac power.
I didn’t even need to add the sensors again. Every time that i used a sensor (either pressed a button or pass in front of a body sensor or open a door with a sensor), it was found automatically just because it was already added to the gateway to China. The Humidity sensors just needed a few minutes (enough to send a reading) and they were found also.
The only sensor that wasn’t found automatically although i pressed it was one of two aqara switches (Oh yes i forgot… aqara switches work perfectly and recognized as AQARA). So i had to add it manually and it was added without problems since aqara switches ARE now included to the child devices of the gateway!!

After that i did a reset to the yeelight bulbs and added them to Singapore (using mi home…) and then created all automations for the switches (single. double, long press) and everything is working PERFECTLY.

Tomorrow i will fix the rest of automations but everything seems to be working perfectly!


#449

That’s good news! Do you mean Aqara wired or wireless switches?
And the most important question is will it work with Google Home? Thanks


#450

What is the advantage of using the singapore server instead of china one ?


#451

Well done stormdreamer! Good for you!
Thanks for the process anyway but unfortunately I cannot replicate and complete the procedure. I understand that, once you sign in to Mainland China and back again to Singapore, you have the chance to see the gateway (red dot on the + on top right of screen) and then you can select it (it lasts for few seconds only) and start the registering process. Unfortunately the process goes in timeout for me and I am not able to complete it. After that, if I search for the gateway again, nothing is found.

I have noticed that my profile in Singapore has 1 device (in settings, just below my name) and it seems to be the gateway (I see a Mi Home logo if I click on help&feedback, but I cannot select it). Would it be related to the fact that we cannot register to any gateway on Singapore? Maybe the gateway is already registered but not in a proper way…


#452

Hi @Tiptip, do you read the messages here? With singapore you can use GoogleHome or Amazon Alexa to awitch your bulbs and the aotomations should work too.


#453

Really great news @stormdreamer, thanks for the feedback.
I am also happy that aqara switches and sensors work too, because I have some of them.
Unfortunately I have an internet connection breakdown, so I will not be able to try it for a few days.
Do you have any xiaomi cameras or Philips bulbs?


#454

Unfortunately, it does not work for me either. I reset the gateway and I can not detect it. I move on china, reset the device And when I see the notification, I move to Singapore. At this point I see the gateway, the configuration starts but at 100% it goes into timeout. I’ve tried so many times. I had deluded myself. I’m on android With mihome 5.1.29 and latest gateway firmware 1.4.1_154


#455

I have the small wireless square ones NOT the wall switches.
Alexa is working perfectly (directly) so i guess that Google home works also.


#456

What i did is, when i was in Mainland China server, i pressed the gateway button for 5 seconds in order to reset it, then i logged in Singapore server and did a manual scan without success. I then noticed that the yellow flashing in Gateway had stopped so i took it out of ac power, plugged it in again and did a reset AGAIN.
Then i logged in back to mainland china and directly logged in back to Singapore server and when i pressed the manual addition it found the Gateway right away.
I could find it that way (following the same steps) about 8 days ago when i tried again but back then i couldnt finish the installation process as i already said (it timed out) this time it worked perfectly.
The time out (that you mention) happened with the PREVIOUS firmware of the gateway. Since then i received an update to the firmware and this time the process finished without problems.

The gateway is initializing, every sensor works, every bulb works and alexa works. I can turn my lamps on/off from the wireless buttons, have automation and have alexa with yeelight at the same time.

Be careful to have the same firmware in the gateway and the same version of Mi Home as me.
Have in mind that with the latest firmware the gateway is now called “Mi Control Hub” and in Child devices you can find the aqara wireless switches.




#457

Also if you fail, try to do the same process again. Add the gateway BACK to China. Reset it AGAIN and do the steps i did all over again. Just in case that this was now a success for me because of the previous failed attempt.


#458

does this means that all automation settings that was done in China server is all gone and had to be added again in the Singapore server? Thanks


#459

If I were to use a new iphone or android phone, and setup a new Mi Account. Shouldnt I be able to see all the devices that I can add even though I do not have them? I mean lets say for example the Aqara AC Companion, I dont see that. I also cant see any Aqara devices. Now I havent added any Gateway yet. I can see the Mi Control Hub and Mijia sensors

Can you see the aircon companion controller in your device list?


#460

I will try again and again, thanks. In the procedure, it seems the gateways (ver. 1.4.1_154.0143) is working well, since it gives “connection complete” message (in Chinese) after ca 50% (with blue light turning off), so there could be an issue on Singapore server when the Android app (ver. 5.1.29) is trying to connect back to my wifi for completing the procedure. Maybe they haven’t “activated” all users yet…


#461

it’s exactly the same thing that I think. The gateway connects to my wifi network (I can also verify from the list of devices connected to my local network on the router), but can not finalize the installation of the gateway. I tried on android with MiHome 5.1.29 and last firmware 1.4.1_154.143. I just can not understand why I can not configure them. The only plausible explanation is that there will be a geolocalized block. Most probably, only a few countries can configure it for now on singapore servers. I live in Italy, if I’m not mistaken the previous user is Greek (and xiaomi has formalized the arrival in the market both in Greece and in Spain . Maybe it’s not a coincidence


#462

It’s all working for me…in Singapure server​:+1::+1::+1: