Lightstrip "working properly" but no light showing

I already own a couple of bulbs and lightstrips and so for I never encountered any kind of problem. My latest addition though does not light up (it didn’t even during the setup process).
So e.g. even though I turned the device on and the color is switched to red etc. (it’s even showing in the app), there is simply no light on the strip. How is that possible? I thought that if the LED should be broken, that the software would recognize it.

What if you use your mobile network to control the device?

Still no light.
The ledstrip appears in the app, it can be turned on/off, I can switch the colors and everything. It seems to be working fine… as long as you do not look at the ledstrip itself and realize that there is no light.

As of now I tried the following:

  • reset to factory default and configure it all over again (multiple times).
  • use the button on the device itself
  • reset and reconfigure from another mobile device (both android and iOS)
  • access the device from mobile network

Nothing worked.

I remember that the device tried to run a firmware update the very first time I did the setup process. For a brief second it gave me an error message before it disappeared and continued “successfully”. The current firmware is “1.4.1_32”. Is it possibly that something happened while the firmware got updated and that another update (once a new version is released) might fix this ?

I really cannot believe that the device could actually be “broken”.

Fingers crossed…

You can connect your lightstrip successfully but can not control it by app or even the button on the strip itself, right? It sounds a hardware issue, could you ask for a refund or replacement from the retailer?

Right. Cannot control it, even though the app e.g. says that everything is fine.
I asked the retailer (, where I bought it for about 31 USD) and they offered a 7 USD refund in store credit.