Issue related with MIJIA desk lamp

I’ve already control MIJIA desk lamp with Yeelight app and IFTTT services, however I am wondering if I could use IOS homekit with this lamp. I find there is some tutorials showing that it is possible to implement homekit with Xiaomi router, but the article says this function only support with this particular router. Meanwhile, there is an article about how to install homebridge NodeJS server.

So is it possible to use router running OpenWrt to connect desk lamp with homekit?

If you can install homebridge on your Openwrt router, then you can have homekit with your MIJIA desk lamp.
We have developed a plugin for homebridge called “homebridge-yeelight”, you can “npm -g install homebridge-yeelight”. Two things need to be noted:

  1. You need to enable developer mode for your device through Yeelight app.
  2. You need to update your MIJIA desk lamp to latest firmware 1.2.9_xx (which is still only available to 20% users, you may wait one or two days until it’s fully published).
1 Like

@weiwei I got the firmware update last night.
it works with homebridge! this is brilliant, and thanks!!!

During the firmware update, it was stuck at 30% for ~5mins. At this, the power source wasn’t plugged in.
I went back to settings, and it was same issue. (See screencap)
So, I exited the app, and my firmware was up to date.

Thanks for reporting this. We will take a look.

I can’t update my MIJIA desk lamp firmware from 1.2.6_24 to 1.2.9_43 by YEELIGHT which is updated (its version 2.4.13). When try to update it basically goes to 100% in 30 seconds and then it stops and nothing happens, I even have waited an hour once. My phone is Samsung Galaxy Note 4.

What’s the solution? Please help me.

The update traffic sometimes got blocked by ISP. if possible, could you setup another phone as AP and connect the lamp to it and do the firmware update.

maybe for future release, it could be a 2 step process for firmware:

  1. download (background) and can be enabled or disabled based user preference?
  2. update (user engaged)

also, I didn’t see an option to do collective update.
i now have 3 strips, 5, and 2 lamps (1 of each is still packed and backup). i’m really loving your products!!!

on a side note, not long ago, who would have thought that we would have software inside a humble light bulb :smiley:

Thanks for your support! We are really happy that you like our products.
For backgroup firmware download, we have considered this feature once but somehow didn’t implement it. We will re-consider this.

Thank you very much for your quick response.
I did as advised, my problem got solved easily.
After the update I couldn’t understand any change. Can you elaborate on changes in this new version of firmware.
Again thanks for your help.

one of the new feature is dev mode, and when enabled it allows you to control this lamp via apple home when you’ve homebridge and yeelight plugin installed.

This is the release note:

  1. enhanced click event handling
  2. turn on @minimum brightness by clockwise spin of knob
  3. bug fixing and stability improvement
  4. developer mode support (works with latest Yeelight APP)

@weiwei I wonder if it’s safe to update the firmware as I am using this lamp outside China, could you please advice me if it’s safe to update? Thanks.

It’s 100% percent safe, we did lots of regression test before releasing new firmware update.

Hi, I am also having the same problem as some users here. I can’t update my desklamp either. It is currently on firmware 1.2.6_22 and I am attempting to upgrade to version 1.2.9_47. I have tried with both the MIJIA app as well as the Yeelight app on both iOS and Android and they were both unsuccessful. MIJIA App pauses at the 30% mark but goes all the way to the “Installing” process but gets stuck there forever, while the Yeelight stops at 30% and gets stuck there forever. If I close the app and restart it, the whole process will start from the beginning again.

Any ideas on how to fix this issue? I have updated the firmware in the past before with no problems (I am still at the same location with the same internet provider). Please help, I would really like to update my firmware. Thanks for all your help.

iOS Device: iPhone 7 Plus 128GB iOS 10.3.1
Android Device: OnePlus 3 OxygenOS 4.1.1 (Android 7.1.1) Stock Firmware

Could you switch to a locale and try again? If you are using Singapore, please connect to China mainland or vice versa.

Hi Weiwei,

Thank you for the advice. This worked great. My locale was previously set to Singapore and by switching to China I was able to update my firmware.

Here are the steps I took in case anyone has the same issue:

  1. Unpair device
  2. Change locale (from Singapore to China or vice versa)
  3. Re-setup your device (Add device, select type, enter wifi password etc)
  4. Perform update (stopped momentarily at 30% and 60% but proceeds on finishing)
  5. Unpair device
  6. Set locale back to your original

The reason I returned it back to the original locale is because all my other devices are in the other locale so I can manage all the device at once.

Hope this helps anyone with the firmware update problem.