Homebridge plugin


#146

这个log表明homebridge正在和灯泡做心跳,是正常的log。你现在是看不到灯泡吗?还是其他的问题?


#147

对的 我在Home App内尝试添加灯泡但是始终找不到我的灯泡@weiwei

准确来说我的homebridge服务就没法在Home app上添加(无法找到)

希望能找到解决方法 :grinning:


#148

你可以这样试验一下:停掉homebridge服务,然后清理 ~/.homebridge/accessory 和 ~/.homebridge/persistent 下面的文件。改一下~/.homebridge/config.json,把name对应的那个mac地址,随便改一位。然后重启服务。


#149

你好,我现在在日本,电压100V,请问yelight的灯泡在日本可以使用吗?

Ps:请问内测群怎么申请加入呢?

Ps2:灯带的Wi-Fi会在路由器重启后无法正常接入,指示灯虽然常亮但是设备离线,需要把电源重连。用的路由是小米路由器pro。


#150

你好,你可以在美国亚马逊上购买110v版本的灯泡。1)我们没有内测群;2)部分路由器重启后设备离线的问题,我们已经修复,灯带固件已经提交测试,请留意固件升级。


#151

i dont speak chinese but the amount of support you guys give is amazing, you will conquer the world.


#152

Thanks for your words, we will do something better :grinning:


#153

After working for a while, the Yeelight bulb is not responding. I have to re-run homebridge and most of the time the bulb is not discoverable when I run homebridge. Here’s what it looks like most of the time:

[2017-07-14 22:12:39] Loaded plugin: homebridge-http
[2017-07-14 22:12:39] Registering accessory ‘homebridge-http.Http’
[2017-07-14 22:12:39] —
failed to load BLE module!
[2017-07-14 22:12:39] Loaded plugin: homebridge-yeelight
[2017-07-14 22:12:39] Registering platform ‘homebridge-yeelight.yeelight’
[2017-07-14 22:12:39] —
[2017-07-14 22:12:39] Loaded config.json with 0 accessories and 1 platforms.
[2017-07-14 22:12:39] —
[2017-07-14 22:12:39] Loading 1 platforms…
[2017-07-14 22:12:39] [yeelight] Initializing yeelight platform…
[2017-07-14 22:12:39] [yeelight] YeePlatform Init
Scan this code with your HomeKit App on your iOS device to pair with Homebridge:

┌────────────┐
│ 031-45-154 │
└────────────┘

[2017-07-14 22:12:39] [yeelight] DidFinishLaunching
no ble cap, skip ble device discovery
[2017-07-14 22:12:39] Homebridge is running on port 51826.
add to multicast group
listen on 0.0.0.0
no did or loc found!

I have to turn the Dev Mode off and on again many times and if I’m lucky, it’s discoverable (then disconnected again after a while).
Any idea how to fix this?


#154

What’s your router? If it’s openwrt based system, you need to turn off one IGMP related option.


#155

Mine is Huawei HG8045A. And IGMP is off


#156

Enable IGMP and try again please.


#157

I turned on IGMP and still got the same error. Any specific configuration needed for IGMP setting? Nonetheless, I tried using “Yeti - smart home automation” which was using dev mode on the LED bulb to control it, and it worked fine. I also tested the demo .exe on yeelight website and it worked too.

There was also an accessoriescache file in the HOME.homebridge\accesories folder. I deleted it by (purposeful xD) mistake and now homebridge can’t even find the bulb anymore (it used to and Siri could control the bulb back then).


#158

I looked into the index.js and found this:

// updateReachability seems have bug, but remove the accessory will cause // the name of the light gone, leave the user to decide...

Could it be that my problem exists because I turned off developer mode while Homebridge was retrying to reconnect to the bulb (after working fine for like 15 mins)? After that, I couldn’t turn the developer mode back on (the app said “save unsuccessful”) and I had to restart the Yeelight app on iOS (or re-add the bulb I don’t remember). Now I can’t even connect the bulb to the Bridge, it can’t find the bulb.

FYI it was working with Homebridge without IGMP turned on, the connection is just a bit unstable (but if I had left it that way, it might had worked again).


#159

Any ideas what could the problem be? Please?


#160

请问你能教我这些命令具体应该怎么打吗@weiwei


#161

想问下weiwei,为什么2个灯泡安装之后yeebridge只能识别到一个?
还有想问下吸顶灯有办法在homekit调节色温吗?


#162

两个灯泡都打开极客模式了吗? 确认都打开了,把那个找不到的短电再通电试试


#163

I got the bulb to work again. But it keeps showing “No response” in the Home app after a while even though homebridge shows that the bulb is still connected to homebridge.


#164

Is this plugin always using the music mode? Because I have a home assistant and homebridge setup at the same raspberry pi and having issues. At home assistant I can disable the music mod. Is it possible with homebridge plugin too?

Thank you.


#165

我的设备是yeelight台灯,在mac安装了homebridge和yeelight插件之后,在iOS Home app中是可以正常使用的。

当我用树莓派3安装homebridge之后,iOS Home app可以发现homebridge,能够正常添加。但是当安装yeelight插件
之后,Home app无法找到任何设备,是什么原因呢?