Connection timeout issue


Hi all,

If you have connection timeout issue of Yeelight Lightstrip, and the strip has shown in your router’s DHCP list, please have a check if your xiaomi account is bigger than 4294967295 (32bit). If so, you can have a try with the following:

1、Logout your account and login with account:, Password: yeelink1234 from Yeelight application.
2、Try to connect device with the account. Update firmware once connected, then reset your device and try again with your account.

It would be great if you delete the device from Yeelight after firmware updated.

You can find xiaomi account and firmware update item from the pic.


Can not to connect to Strip using my wifi or phone
Yeelight Striplight Connection Timed Out
Can't connect bedside 2 to Yeelight/mi home app
Lightstrip connection failed
Yeelight Strip does not Connect to WIFI
Connection time out, not able to setup device
Yeeligth strip Connection timeout

This is to fix very very old light strip firmware issue. The old firmware can’t handle very big user id (internally it uses 4 bytes to store uid, however, the uid grows so fast and overflows an integer).

Only try this method if your uid is bigger than 4294967295.


Can not to connect to Strip using my wifi or phone



I have the problem in connection with the lightstrips.I have 2 lightstrips.The one which I bought last year,It works normally.The other one which I bought this month.But I always had problem in connection.The problem is 100% same as the Pspower.I tried the method to change ID into it still not ID is 1319269032


Is there some special characters in your network SSID or Password?