Can't Link Yeelight Actions to Google Home


#62

I can’t see my Yeelight on Google Home at all. There a browser to sign in Yeelight with Mi Account and says " Linking your Yeelight Actions to Google Home." It then completes but no device is added. I’ve tried using Android phone and iPhone as well. Thanks.
ID: 163042027


#63

@chungtsz @true76
I found your bulb connect to China server, this is not supported.
Please connect to Singapore server or US server.


#64

I changed from China to Singapore server but can’t see any device after Yeelight action. My id is 1678930349


#65

@shihchau
I found your device still in the China server, please reset bulb before change server.


#66

I have set my locale to Singapore in Mi Home. Is that what I am supposed to do?

Is there a step-by-step instructions to get it done?


#67

Thanks. Found the problem now. Fixed


#68

You can find step-by-step installation instructions and voice command instructions in Yeelight app.


#69

Can you provide the step-by-step guide to solve my problem. eg, are these correct?

  1. install Yeelight app. Yeelight said server is Singapore. My miHome locale is also Singapore.
  2. reset the bulb by turning off and on for 5 times (with changing color after that)
  3. add the device to Yeelight app successfully and able to control it
  4. go to Google Home app “Home control” to add Yeelight Actions. My Home control screen only has Google Home Mini device.
  5. After Sign in to Yeelight xiaomi account, the app’s progress bar moves for a second and return to the same screen with only my Google Home device.

#70

We will look into it.


#71

Are my steps correct?

How to get it work?


#72

@shihchau
Your steps are correct.
Are you use different xiaomi account to login GooglHome Yeelight plugin?


#73

My apology. You are right. My account in the 2 apps are somehow different. It works now.


#74

Hi I have the same problem. Cannot link my Yeelight actions to Google home. It logins but doesn’t go to the next step. I have 5 Yeelight colour WiFi bulbs properly configured in the Yeelight app. Connected to Singapore server. ID is 1590042612.


#75

@Quantumcosmos
OK, i record your ID, please link it again, if you encounter error, please take a screenshot to me.


#76

Hi still not working. When I login after selecting link Yeelight action from Google home, I get this screen and no matter how many times I click the sign in button. It keeps on returning to screen


#77

Same here:((
after resetting all and setting the server to Singapore

ID 1667220507

4 color and 1 white bulb, Bedside Lamp 2nd and Desk Lamp.


#78

Same problem here.

Google Home app > home controls > add > yeelight actions > login and logging in just returns me to the same login page.

Are the login servers down?


#79

Yeah, same issue also here.
Something’s wrong.
Id: 1771565738


#80

So I finally got it to work. No matter how much I tried on my android samsung galaxy note 8, I was always stuck on the sign in screen while trying to link from Google home. Decided to try this on my iPad (Google home app), and it linked properly and I was able to assign all the bulbs to a room


#81

I have the same problem, unable to link to Google home. Please help

Thanks