Can't connect to Yeelight RGB bulbs


#1

Hello,

Been trying for a few hours and can’t connect. I have bought multiple bulbs and none of them work. I have followed the instructions and the Yeelight app states 25% and then connection failed. I’ve reset the bulbs and tried again, but I am tired of doing that now!

I am using the Yeelight app on an iPhone with the latest OS installed. I have a 2.5ghz network to connect to and no special characters in the id or the password.

I also pinged the server you suggested in another post:

Pinging ot.io.mi.com [120.92.96.242] with 32 bytes of data:
Reply from 120.92.96.242: bytes=32 time=317ms TTL=39
Reply from 120.92.96.242: bytes=32 time=318ms TTL=39
Reply from 120.92.96.242: bytes=32 time=317ms TTL=39
Reply from 120.92.96.242: bytes=32 time=317ms TTL=39

I am out of ideas now.

Thanks,

Mark.


#2

You can only use 2.4G network and make sure your encryption method is WPA/WPA2.
After failure, you can logon to the router and check if the bulb is in DHCP list.


#3

Hello

I resolved my using my iPhone and iPad.

On the phone I set up a hotspot with the same details as the one on the network the bulbs would connect too. Then turn your wifi off at home (or chance SSID). Then used the ipad to connect to that and used the Yeelight app to add the bulbs. Turn the hotspot off and the home network back on and it should work.

It worked fine and allowed me to add all my bulbs. Because you are signed in anything you add is shared across the servers so on my phone all the bulbs are there.

One note - if you plan to use Google Home or similar I have found I have to use the US Server for Yeelight which you can change in your settings.

Hopefully Yeelight will find a way round the problem which many have because it’s very frustrating!!


#4

Thank you very much!
I had the same problem and your solution has worked for me.
Thanks!