Alexa Skill - OAuth2 Issue


I’m trying to set up my Alexa to control my Yeelights, which has worked in the past.
This time, I can’t connect the Alexa Skill to my Xiaomi account, it’s giving an OAuth2 Error:
invalid redirect uri

The URL with the error is:[Removed for privacy]&scope=1+3+6000&

For some reason it’s using in the redirect_uri, but I’m in Australia, could that be the problem?

I think this issue is with Xiaomi’s OAuth2 configuration.

It’s also worth noting I’ve tried the mobile Alexa app and the website.

I’ve have exactly the same issue. I’m in Australia, have two yeelight color globes, two strip lights that have worked perfectly for about 3 months. Looks like Amazon app has upgraded to allow Australian location. I get the uri error now. Skill won’t enable. Same error. Frustrating.

We will fix it as soon as possible.

The issue is fixed. Please have a test.

The issue is fixed. Please have a try.

Thank you for fixing so quickly. It’s working for me now.

I am also having an issue where Alexa can’t find my yeelight 2 colour for some reason. And I bought another yeelight 2 colour and the wifi will not appear in the settings so I am unable to pair it in my app.