After upgrade wont turn on or reset

After I upgraded my yeelight lightstrip, it won’t turn on or even reset.
what can I do to fix it?

which version, 1.4.1_34?
Is button working well? had you tried to press the button to power on or off?

I can’t recall the version.
I’ve tried to press the on/off button, there is no other way to (try) turn it on/off since it is shown offline in the app, unless there is.
How would I know if the button is working well? If you mean that when I press the button then the indicator light should light, then you are right, there is a button failure. If you mean the “click” sound, then it works great.

I should mention that I haven’t taken it off the box yet since the whole thing happened when I was testing the product. It was working well, had communication with my phone and after 2 minutes it notified me about the upgrade. Once upgraded never powered up again, or communicated with my phone.

I have a video (if you want it) which I send it to the purchasing site-store, in order to resolve the matter, since as I told you it is still in the box.

I mean if you can turn on or off the lightstrip by clicking the button to check if it works well.
Also it will be useful if you can provide a video.

Nothing happens when I push the button.

HERE is the video, hope it’ll help.

It’s been 11 days now and no reply or suggestion from your side.

Should I consider it to be a hardware issue?

Nothing came out by watching the video?

OK, it looks like a hardware issue, could you contact your reseller to replace it for you?

Thank you.
I’ve already contacted with the reseller and we are trying to figure out the how, due to (very very) long distance between us.